summaryrefslogtreecommitdiff
path: root/packages/textproc
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-16 21:45:14 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2014-07-16 21:45:14 +0200
commitace7970ea96b21079db8c487928425d98664ae24 (patch)
tree08c759a56ae011de651f8f97f2b55ac904c0e1ea /packages/textproc
parent17c4f44b287fdc7e617422a070cb17cb97b74410 (diff)
downloadembtoolkit-ace7970ea96b21079db8c487928425d98664ae24.tar.gz
embtoolkit-ace7970ea96b21079db8c487928425d98664ae24.tar.bz2
embtoolkit-ace7970ea96b21079db8c487928425d98664ae24.tar.xz
Packages: libxml2: fix installed xml2-config sctipts and move it among textproc packages
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/textproc')
-rw-r--r--packages/textproc/libxml2/libxml2.kconfig49
-rw-r--r--packages/textproc/libxml2/libxml2.mk52
2 files changed, 101 insertions, 0 deletions
diff --git a/packages/textproc/libxml2/libxml2.kconfig b/packages/textproc/libxml2/libxml2.kconfig
new file mode 100644
index 0000000..b1166de
--- /dev/null
+++ b/packages/textproc/libxml2/libxml2.kconfig
@@ -0,0 +1,49 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file libxml.kconfig
+# \brief libxml.kconfig of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date December 2009
+################################################################################
+
+config EMBTK_HAVE_LIBXML2
+ bool "Have libxml2"
+ select KEMBTK_UCLIBC_UCLIBC_HAS_FLOATS if EMBTK_CLIB_UCLIBC
+ select KEMBTK_UCLIBC_DO_C99_MATH if EMBTK_CLIB_UCLIBC
+ help
+ libxml2
+choice
+ prompt "libxml version you wish"
+ depends on EMBTK_HAVE_LIBXML2
+ help
+ Here you can choose which version of libxml2 you want to use.
+
+ config EMBTK_LIBXML2_VERSION_2_7_7
+ bool "libxml2-2.7.7"
+endchoice
+
+config EMBTK_LIBXML2_VERSION_STRING
+ string
+ default "2.7.7" if EMBTK_LIBXML2_VERSION_2_7_7
+
+config EMBTK_LIBXML2_NEED_PATCH
+ bool
+config EMBTK_LIBXML2_NEED_AUTORECONF
+ bool
diff --git a/packages/textproc/libxml2/libxml2.mk b/packages/textproc/libxml2/libxml2.mk
new file mode 100644
index 0000000..9700337
--- /dev/null
+++ b/packages/textproc/libxml2/libxml2.mk
@@ -0,0 +1,52 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file libxml.mk
+# \brief libxml.mk of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date December 2009
+################################################################################
+
+LIBXML2_NAME := libxml2
+LIBXML2_VERSION := $(call embtk_get_pkgversion,libxml2)
+LIBXML2_SITE := ftp://xmlsoft.org/libxml2
+LIBXML2_PACKAGE := libxml2-$(LIBXML2_VERSION).tar.gz
+LIBXML2_SRC_DIR := $(embtk_pkgb)/libxml2-$(LIBXML2_VERSION)
+LIBXML2_BUILD_DIR := $(embtk_pkgb)/libxml2-$(LIBXML2_VERSION)
+
+LIBXML2_BINS := xml2-config xmlcatalog xmllint
+LIBXML2_INCLUDES := libxml2
+LIBXML2_LIBS := libxml2* xml2Conf.sh
+LIBXML2_PKGCONFIGS := libxml*.pc
+
+LIBXML2_CONFIGURE_OPTS := --without-python
+
+# FIXME: this should be fixed from upstream libxml2
+pembtk_libxml2conf := $(embtk_sysroot)/usr/$(LIBDIR)/xml2Conf.sh
+pembtk_xml2config := $(embtk_sysroot)/usr/bin/xml2-config
+define embtk_postinstallonce_libxml2
+ sed -e 's;/usr;$(embtk_sysroot)/usr;g' \
+ < $(pembtk_libxml2conf) > $(pembtk_libxml2conf).tmp; \
+ mv $(pembtk_libxml2conf).tmp $(pembtk_libxml2conf)
+ chmod +x $(pembtk_libxml2conf)
+ sed -e 's;=/usr;=$(embtk_sysroot)/usr;g' \
+ < $(pembtk_xml2config) > $(pembtk_xml2config).tmp; \
+ mv $(pembtk_xml2config).tmp $(pembtk_xml2config)
+ chmod +x $(pembtk_xml2config)
+endef