summaryrefslogtreecommitdiff
path: root/packages/x11/compositeproto
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-08-22 20:05:12 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-08-22 20:05:12 +0200
commitdbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd (patch)
treeefb0370771ebdf5143a55cd08ce09942cf213208 /packages/x11/compositeproto
parent4d4894930a92e5101a0f045dc20be4f6ccb21e1f (diff)
downloadembtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.gz
embtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.bz2
embtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.xz
Embtk: drastically improve packages rebuild duration
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/x11/compositeproto')
-rw-r--r--packages/x11/compositeproto/compositeproto.mk9
1 files changed, 6 insertions, 3 deletions
diff --git a/packages/x11/compositeproto/compositeproto.mk b/packages/x11/compositeproto/compositeproto.mk
index cf025f9..db4ba57 100644
--- a/packages/x11/compositeproto/compositeproto.mk
+++ b/packages/x11/compositeproto/compositeproto.mk
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
+# Copyright(C) 2010 Abdoulaye Walsimou GAYE. All rights reserved.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -19,7 +19,7 @@
#
# \file compositeproto.mk
# \brief compositeproto.mk of Embtoolkit
-# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \author Abdoulaye Walsimou GAYE <awg@wembtoolkit.org>
# \date March 2010
################################################################################
@@ -35,7 +35,9 @@ COMPOSITEPROTO_INCLUDES = X11/extensions/compositeproto.h \
COMPOSITEPROTO_LIBS =
COMPOSITEPROTO_PKGCONFIGS = compositeproto.pc
-compositeproto_install: $(COMPOSITEPROTO_BUILD_DIR)/.installed
+compositeproto_install:
+ @test -e $(COMPOSITEPROTO_BUILD_DIR)/.installed || \
+ $(MAKE) $(COMPOSITEPROTO_BUILD_DIR)/.installed
$(COMPOSITEPROTO_BUILD_DIR)/.installed: download_compositeproto \
$(COMPOSITEPROTO_BUILD_DIR)/.decompressed $(COMPOSITEPROTO_BUILD_DIR)/.configured
@@ -89,4 +91,5 @@ compositeproto_clean:
$(Q)-cd $(SYSROOT)/usr/include; rm -rf $(COMPOSITEPROTO_INCLUDES)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(COMPOSITEPROTO_LIBS)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(COMPOSITEPROTO_PKGCONFIGS)
+ $(Q)-rm -rf $(COMPOSITEPROTO_BUILD_DIR)