summaryrefslogtreecommitdiff
path: root/packages/x11/fixesproto
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-08-30 21:07:33 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-08-30 21:07:33 +0200
commitfc9e73f1e87c6e55223158c5d2e2fe8f9d3c2ce5 (patch)
treef0f854815e87328a3f8c749210b2f793d0eaf602 /packages/x11/fixesproto
parentdc8ad05cccf64348b9235bd6aabed302b12ae3ab (diff)
downloadembtoolkit-fc9e73f1e87c6e55223158c5d2e2fe8f9d3c2ce5.tar.gz
embtoolkit-fc9e73f1e87c6e55223158c5d2e2fe8f9d3c2ce5.tar.bz2
embtoolkit-fc9e73f1e87c6e55223158c5d2e2fe8f9d3c2ce5.tar.xz
Packages: convert more (almost all) packages to generic macros
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/x11/fixesproto')
-rw-r--r--packages/x11/fixesproto/fixesproto.kconfig9
-rw-r--r--packages/x11/fixesproto/fixesproto.mk80
2 files changed, 21 insertions, 68 deletions
diff --git a/packages/x11/fixesproto/fixesproto.kconfig b/packages/x11/fixesproto/fixesproto.kconfig
index e777d50..efd7442 100644
--- a/packages/x11/fixesproto/fixesproto.kconfig
+++ b/packages/x11/fixesproto/fixesproto.kconfig
@@ -25,6 +25,7 @@
config EMBTK_HAVE_FIXESPROTO
bool "Have fixesproto"
+ select EMBTK_FIXESPROTO_PKG_IS_TARBZ2
help
fixesproto for X windowing system
choice
@@ -44,3 +45,11 @@ config EMBTK_FIXESPROTO_VERSION_STRING
default "4.1.2" if EMBTK_FIXESPROTO_VERSION_4_1_2
default "4.1" if EMBTK_FIXESPROTO_VERSION_4_1
+config EMBTK_FIXESPROTO_NEED_PATCH
+ bool
+config EMBTK_FIXESPROTO_NEED_AUTORECONF
+ bool
+config EMBTK_FIXESPROTO_PKG_IS_TARGZ
+ bool
+config EMBTK_FIXESPROTO_PKG_IS_TARBZ2
+ bool
diff --git a/packages/x11/fixesproto/fixesproto.mk b/packages/x11/fixesproto/fixesproto.mk
index 5bf0a84..89fc023 100644
--- a/packages/x11/fixesproto/fixesproto.mk
+++ b/packages/x11/fixesproto/fixesproto.mk
@@ -23,72 +23,16 @@
# \date February 2010
################################################################################
-FIXESPROTO_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_FIXESPROTO_VERSION_STRING)))
-FIXESPROTO_SITE := http://xorg.freedesktop.org/archive/individual/proto
-FIXESPROTO_PACKAGE := fixesproto-$(FIXESPROTO_VERSION).tar.bz2
-FIXESPROTO_BUILD_DIR := $(PACKAGES_BUILD)/fixesproto-$(FIXESPROTO_VERSION)
-
-FIXESPROTO_BINS =
-FIXESPROTO_SBINS =
-FIXESPROTO_INCLUDES = X11/extensions/xfixesproto.h X11/extensions/xfixeswire.h
-FIXESPROTO_LIBS =
-FIXESPROTO_PKGCONFIGS = fixesproto.pc
-
-fixesproto_install:
- @test -e $(FIXESPROTO_BUILD_DIR)/.installed || \
- $(MAKE) $(FIXESPROTO_BUILD_DIR)/.installed
-
-$(FIXESPROTO_BUILD_DIR)/.installed: download_fixesproto \
- $(FIXESPROTO_BUILD_DIR)/.decompressed $(FIXESPROTO_BUILD_DIR)/.configured
- $(call embtk_generic_message,"Compiling and installing \
- fixesproto-$(FIXESPROTO_VERSION) in your root filesystem...")
- $(Q)$(MAKE) -C $(FIXESPROTO_BUILD_DIR) $(J)
- $(Q)$(MAKE) -C $(FIXESPROTO_BUILD_DIR) DESTDIR=$(SYSROOT) install
- $(Q)$(MAKE) libtool_files_adapt
- $(Q)$(MAKE) pkgconfig_files_adapt
- @touch $@
-
-download_fixesproto:
- $(call embtk_generic_message,"Downloading $(FIXESPROTO_PACKAGE) \
- if necessary...")
- @test -e $(DOWNLOAD_DIR)/$(FIXESPROTO_PACKAGE) || \
- wget -O $(DOWNLOAD_DIR)/$(FIXESPROTO_PACKAGE) \
- $(FIXESPROTO_SITE)/$(FIXESPROTO_PACKAGE)
-
-$(FIXESPROTO_BUILD_DIR)/.decompressed:
- $(call embtk_generic_message,"Decompressing $(FIXESPROTO_PACKAGE) ...")
- @tar -C $(PACKAGES_BUILD) -xjvf $(DOWNLOAD_DIR)/$(FIXESPROTO_PACKAGE)
- @touch $@
-
-$(FIXESPROTO_BUILD_DIR)/.configured:
- $(Q)cd $(FIXESPROTO_BUILD_DIR); \
- CC=$(TARGETCC_CACHED) \
- CXX=$(TARGETCXX_CACHED) \
- AR=$(TARGETAR) \
- RANLIB=$(TARGETRANLIB) \
- AS=$(CROSS_COMPILE)as \
- LD=$(TARGETLD) \
- NM=$(TARGETNM) \
- STRIP=$(TARGETSTRIP) \
- OBJDUMP=$(TARGETOBJDUMP) \
- OBJCOPY=$(TARGETOBJCOPY) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CXXFLAGS="$(TARGET_CFLAGS)" \
- LDFLAGS="-L$(SYSROOT)/$(LIBDIR) -L$(SYSROOT)/usr/$(LIBDIR)" \
- CPPFLGAS="-I$(SYSROOT)/usr/include" \
- PKG_CONFIG=$(PKGCONFIG_BIN) \
- PKG_CONFIG_PATH=$(EMBTK_PKG_CONFIG_PATH) \
- ./configure --build=$(HOST_BUILD) --host=$(STRICT_GNU_TARGET) \
- --target=$(STRICT_GNU_TARGET) --prefix=/usr --libdir=/usr/$(LIBDIR) \
- --disable-malloc0returnsnull
- @touch $@
-
-fixesproto_clean:
- $(call embtk_generic_message,"cleanup fixesproto-$(FIXESPROTO_VERSION)...")
- $(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(FIXESPROTO_BINS)
- $(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(FIXESPROTO_SBINS)
- $(Q)-cd $(SYSROOT)/usr/include; rm -rf $(FIXESPROTO_INCLUDES)
- $(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(FIXESPROTO_LIBS)
- $(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(FIXESPROTO_PKGCONFIGS)
- $(Q)-rm -rf $(FIXESPROTO_BUILD_DIR)*
+FIXESPROTO_NAME := fixesproto
+FIXESPROTO_VERSION := $(call embtk_get_pkgversion,fixesproto)
+FIXESPROTO_SITE := http://xorg.freedesktop.org/archive/individual/proto
+FIXESPROTO_PACKAGE := fixesproto-$(FIXESPROTO_VERSION).tar.bz2
+FIXESPROTO_SRC_DIR := $(PACKAGES_BUILD)/fixesproto-$(FIXESPROTO_VERSION)
+FIXESPROTO_BUILD_DIR := $(PACKAGES_BUILD)/fixesproto-$(FIXESPROTO_VERSION)
+
+FIXESPROTO_BINS =
+FIXESPROTO_SBINS =
+FIXESPROTO_INCLUDES = X11/extensions/xfixesproto.h X11/extensions/xfixeswire.h
+FIXESPROTO_LIBS =
+FIXESPROTO_PKGCONFIGS = fixesproto.pc