summaryrefslogtreecommitdiff
path: root/packages/x11/inputproto/inputproto.mk
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-08-30 21:07:33 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-08-30 21:07:33 +0200
commitfc9e73f1e87c6e55223158c5d2e2fe8f9d3c2ce5 (patch)
treef0f854815e87328a3f8c749210b2f793d0eaf602 /packages/x11/inputproto/inputproto.mk
parentdc8ad05cccf64348b9235bd6aabed302b12ae3ab (diff)
downloadembtoolkit-fc9e73f1e87c6e55223158c5d2e2fe8f9d3c2ce5.tar.gz
embtoolkit-fc9e73f1e87c6e55223158c5d2e2fe8f9d3c2ce5.tar.bz2
embtoolkit-fc9e73f1e87c6e55223158c5d2e2fe8f9d3c2ce5.tar.xz
Packages: convert more (almost all) packages to generic macros
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/x11/inputproto/inputproto.mk')
-rw-r--r--packages/x11/inputproto/inputproto.mk82
1 files changed, 13 insertions, 69 deletions
diff --git a/packages/x11/inputproto/inputproto.mk b/packages/x11/inputproto/inputproto.mk
index dd86196..0607690 100644
--- a/packages/x11/inputproto/inputproto.mk
+++ b/packages/x11/inputproto/inputproto.mk
@@ -23,73 +23,17 @@
# \date February 2010
################################################################################
-INPUTPROTO_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_INPUTPROTO_VERSION_STRING)))
-INPUTPROTO_SITE := http://xorg.freedesktop.org/archive/individual/proto
-INPUTPROTO_PACKAGE := inputproto-$(INPUTPROTO_VERSION).tar.bz2
-INPUTPROTO_BUILD_DIR := $(PACKAGES_BUILD)/inputproto-$(INPUTPROTO_VERSION)
-
-INPUTPROTO_BINS =
-INPUTPROTO_SBINS =
-INPUTPROTO_INCLUDES = X11/extensions/XI2.h X11/extensions/XI2proto.h \
- X11/extensions/XI.h X11/extensions/XIproto.h
-INPUTPROTO_LIBS =
-INPUTPROTO_PKGCONFIGS = inputproto.pc
-
-inputproto_install:
- @test -e $(INPUTPROTO_BUILD_DIR)/.installed || \
- $(MAKE) $(INPUTPROTO_BUILD_DIR)/.installed
-
-$(INPUTPROTO_BUILD_DIR)/.installed: download_inputproto \
- $(INPUTPROTO_BUILD_DIR)/.decompressed $(INPUTPROTO_BUILD_DIR)/.configured
- $(call embtk_generic_message,"Compiling and installing \
- inputproto-$(INPUTPROTO_VERSION) in your root filesystem...")
- $(Q)$(MAKE) -C $(INPUTPROTO_BUILD_DIR) $(J)
- $(Q)$(MAKE) -C $(INPUTPROTO_BUILD_DIR) DESTDIR=$(SYSROOT) install
- $(Q)$(MAKE) libtool_files_adapt
- $(Q)$(MAKE) pkgconfig_files_adapt
- @touch $@
-
-download_inputproto:
- $(call embtk_generic_message,"Downloading $(INPUTPROTO_PACKAGE) \
- if necessary...")
- @test -e $(DOWNLOAD_DIR)/$(INPUTPROTO_PACKAGE) || \
- wget -O $(DOWNLOAD_DIR)/$(INPUTPROTO_PACKAGE) \
- $(INPUTPROTO_SITE)/$(INPUTPROTO_PACKAGE)
-
-$(INPUTPROTO_BUILD_DIR)/.decompressed:
- $(call embtk_generic_message,"Decompressing $(INPUTPROTO_PACKAGE) ...")
- @tar -C $(PACKAGES_BUILD) -xjvf $(DOWNLOAD_DIR)/$(INPUTPROTO_PACKAGE)
- @touch $@
-
-$(INPUTPROTO_BUILD_DIR)/.configured:
- $(Q)cd $(INPUTPROTO_BUILD_DIR); \
- CC=$(TARGETCC_CACHED) \
- CXX=$(TARGETCXX_CACHED) \
- AR=$(TARGETAR) \
- RANLIB=$(TARGETRANLIB) \
- AS=$(CROSS_COMPILE)as \
- LD=$(TARGETLD) \
- NM=$(TARGETNM) \
- STRIP=$(TARGETSTRIP) \
- OBJDUMP=$(TARGETOBJDUMP) \
- OBJCOPY=$(TARGETOBJCOPY) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CXXFLAGS="$(TARGET_CFLAGS)" \
- LDFLAGS="-L$(SYSROOT)/$(LIBDIR) -L$(SYSROOT)/usr/$(LIBDIR)" \
- CPPFLGAS="-I$(SYSROOT)/usr/include" \
- PKG_CONFIG=$(PKGCONFIG_BIN) \
- PKG_CONFIG_PATH=$(EMBTK_PKG_CONFIG_PATH) \
- ./configure --build=$(HOST_BUILD) --host=$(STRICT_GNU_TARGET) \
- --target=$(STRICT_GNU_TARGET) --prefix=/usr --libdir=/usr/$(LIBDIR) \
- --disable-malloc0returnsnull
- @touch $@
-
-inputproto_clean:
- $(call embtk_generic_message,"cleanup inputproto-$(INPUTPROTO_VERSION)...")
- $(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(INPUTPROTO_BINS)
- $(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(INPUTPROTO_SBINS)
- $(Q)-cd $(SYSROOT)/usr/include; rm -rf $(INPUTPROTO_INCLUDES)
- $(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(INPUTPROTO_LIBS)
- $(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(INPUTPROTO_PKGCONFIGS)
- $(Q)-rm -rf $(INPUTPROTO_BUILD_DIR)*
+INPUTPROTO_NAME := inputproto
+INPUTPROTO_VERSION := $(call embtk_get_pkgversion,inputproto)
+INPUTPROTO_SITE := http://xorg.freedesktop.org/archive/individual/proto
+INPUTPROTO_PACKAGE := inputproto-$(INPUTPROTO_VERSION).tar.bz2
+INPUTPROTO_SRC_DIR := $(PACKAGES_BUILD)/inputproto-$(INPUTPROTO_VERSION)
+INPUTPROTO_BUILD_DIR := $(PACKAGES_BUILD)/inputproto-$(INPUTPROTO_VERSION)
+
+INPUTPROTO_BINS =
+INPUTPROTO_SBINS =
+INPUTPROTO_INCLUDES = X11/extensions/XI2.h X11/extensions/XI2proto.h \
+ X11/extensions/XI.h X11/extensions/XIproto.h
+INPUTPROTO_LIBS =
+INPUTPROTO_PKGCONFIGS = inputproto.pc