summaryrefslogtreecommitdiff
path: root/packages/x11/inputproto
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-08-22 20:05:12 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-08-22 20:05:12 +0200
commitdbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd (patch)
treeefb0370771ebdf5143a55cd08ce09942cf213208 /packages/x11/inputproto
parent4d4894930a92e5101a0f045dc20be4f6ccb21e1f (diff)
downloadembtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.gz
embtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.bz2
embtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.xz
Embtk: drastically improve packages rebuild duration
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/x11/inputproto')
-rw-r--r--packages/x11/inputproto/inputproto.mk23
1 files changed, 8 insertions, 15 deletions
diff --git a/packages/x11/inputproto/inputproto.mk b/packages/x11/inputproto/inputproto.mk
index 29404a5..f06a7c9 100644
--- a/packages/x11/inputproto/inputproto.mk
+++ b/packages/x11/inputproto/inputproto.mk
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2009 GAYE Abdoulaye Walsimou. All rights reserved.
+# Copyright(C) 2009 Abdoulaye Walsimou GAYE. All rights reserved.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -19,7 +19,7 @@
#
# \file inputproto.mk
# \brief inputproto.mk of Embtoolkit
-# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# \date December 2009
################################################################################
@@ -35,13 +35,9 @@ INPUTPROTO_INCLUDES = X11/extensions/XI2.h X11/extensions/XI2proto.h \
INPUTPROTO_LIBS =
INPUTPROTO_PKGCONFIGS = inputproto.pc
-ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
-PKG_CONFIG_PATH=$(SYSROOT)/usr/lib32/pkgconfig
-else
-PKG_CONFIG_PATH=$(SYSROOT)/usr/lib/pkgconfig
-endif
-
-inputproto_install: $(INPUTPROTO_BUILD_DIR)/.installed
+inputproto_install:
+ @test -e $(INPUTPROTO_BUILD_DIR)/.installed || \
+ $(MAKE) $(INPUTPROTO_BUILD_DIR)/.installed
$(INPUTPROTO_BUILD_DIR)/.installed: download_inputproto \
$(INPUTPROTO_BUILD_DIR)/.decompressed $(INPUTPROTO_BUILD_DIR)/.configured
@@ -93,10 +89,7 @@ inputproto_clean:
$(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(INPUTPROTO_BINS)
$(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(INPUTPROTO_SBINS)
$(Q)-cd $(SYSROOT)/usr/include; rm -rf $(INPUTPROTO_INCLUDES)
- $(Q)-cd $(SYSROOT)/usr/lib; rm -rf $(INPUTPROTO_LIBS)
- $(Q)-cd $(SYSROOT)/usr/lib/pkgconfig; rm -rf $(INPUTPROTO_PKGCONFIGS)
-ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
- $(Q)-cd $(SYSROOT)/usr/lib32; rm -rf $(INPUTPROTO_LIBS)
- $(Q)-cd $(SYSROOT)/usr/lib32/pkgconfig; rm -rf $(INPUTPROTO_PKGCONFIGS)
-endif
+ $(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(INPUTPROTO_LIBS)
+ $(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(INPUTPROTO_PKGCONFIGS)
+ $(Q)-rm -rf $(INPUTPROTO_BUILD_DIR)