summaryrefslogtreecommitdiff
path: root/packages/x11/renderproto/renderproto.mk
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-08-30 21:07:33 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-08-30 21:07:33 +0200
commitfc9e73f1e87c6e55223158c5d2e2fe8f9d3c2ce5 (patch)
treef0f854815e87328a3f8c749210b2f793d0eaf602 /packages/x11/renderproto/renderproto.mk
parentdc8ad05cccf64348b9235bd6aabed302b12ae3ab (diff)
downloadembtoolkit-fc9e73f1e87c6e55223158c5d2e2fe8f9d3c2ce5.tar.gz
embtoolkit-fc9e73f1e87c6e55223158c5d2e2fe8f9d3c2ce5.tar.bz2
embtoolkit-fc9e73f1e87c6e55223158c5d2e2fe8f9d3c2ce5.tar.xz
Packages: convert more (almost all) packages to generic macros
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/x11/renderproto/renderproto.mk')
-rw-r--r--packages/x11/renderproto/renderproto.mk80
1 files changed, 12 insertions, 68 deletions
diff --git a/packages/x11/renderproto/renderproto.mk b/packages/x11/renderproto/renderproto.mk
index 79d4b59..118e425 100644
--- a/packages/x11/renderproto/renderproto.mk
+++ b/packages/x11/renderproto/renderproto.mk
@@ -23,72 +23,16 @@
# \date March 2010
################################################################################
-RENDERPROTO_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_RENDERPROTO_VERSION_STRING)))
-RENDERPROTO_SITE := http://xorg.freedesktop.org/archive/individual/proto
-RENDERPROTO_PACKAGE := renderproto-$(RENDERPROTO_VERSION).tar.bz2
-RENDERPROTO_BUILD_DIR := $(PACKAGES_BUILD)/renderproto-$(RENDERPROTO_VERSION)
-
-RENDERPROTO_BINS =
-RENDERPROTO_SBINS =
-RENDERPROTO_INCLUDES = X11/extensions/render.h X11/extensions/renderproto.h
-RENDERPROTO_LIBS =
-RENDERPROTO_PKGCONFIGS = renderproto.pc
-
-renderproto_install:
- @test -e $(RENDERPROTO_BUILD_DIR)/.installed || \
- $(MAKE) $(RENDERPROTO_BUILD_DIR)/.installed
-
-$(RENDERPROTO_BUILD_DIR)/.installed: download_renderproto \
- $(RENDERPROTO_BUILD_DIR)/.decompressed $(RENDERPROTO_BUILD_DIR)/.configured
- $(call embtk_generic_message,"Compiling and installing \
- renderproto-$(RENDERPROTO_VERSION) in your root filesystem...")
- $(Q)$(MAKE) -C $(RENDERPROTO_BUILD_DIR) $(J)
- $(Q)$(MAKE) -C $(RENDERPROTO_BUILD_DIR) DESTDIR=$(SYSROOT) install
- $(Q)$(MAKE) libtool_files_adapt
- $(Q)$(MAKE) pkgconfig_files_adapt
- @touch $@
-
-download_renderproto:
- $(call embtk_generic_message,"Downloading $(RENDERPROTO_PACKAGE) \
- if necessary...")
- @test -e $(DOWNLOAD_DIR)/$(RENDERPROTO_PACKAGE) || \
- wget -O $(DOWNLOAD_DIR)/$(RENDERPROTO_PACKAGE) \
- $(RENDERPROTO_SITE)/$(RENDERPROTO_PACKAGE)
-
-$(RENDERPROTO_BUILD_DIR)/.decompressed:
- $(call embtk_generic_message,"Decompressing $(RENDERPROTO_PACKAGE) ...")
- @tar -C $(PACKAGES_BUILD) -xjvf $(DOWNLOAD_DIR)/$(RENDERPROTO_PACKAGE)
- @touch $@
-
-$(RENDERPROTO_BUILD_DIR)/.configured:
- $(Q)cd $(RENDERPROTO_BUILD_DIR); \
- CC=$(TARGETCC_CACHED) \
- CXX=$(TARGETCXX_CACHED) \
- AR=$(TARGETAR) \
- RANLIB=$(TARGETRANLIB) \
- AS=$(CROSS_COMPILE)as \
- LD=$(TARGETLD) \
- NM=$(TARGETNM) \
- STRIP=$(TARGETSTRIP) \
- OBJDUMP=$(TARGETOBJDUMP) \
- OBJCOPY=$(TARGETOBJCOPY) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CXXFLAGS="$(TARGET_CFLAGS)" \
- LDFLAGS="-L$(SYSROOT)/$(LIBDIR) -L$(SYSROOT)/usr/$(LIBDIR)" \
- CPPFLGAS="-I$(SYSROOT)/usr/include" \
- PKG_CONFIG=$(PKGCONFIG_BIN) \
- PKG_CONFIG_PATH=$(EMBTK_PKG_CONFIG_PATH) \
- ./configure --build=$(HOST_BUILD) --host=$(STRICT_GNU_TARGET) \
- --target=$(STRICT_GNU_TARGET) --prefix=/usr --libdir=/usr/$(LIBDIR) \
- --disable-malloc0returnsnull
- @touch $@
-
-renderproto_clean:
- $(call embtk_generic_message,"cleanup renderproto-$(RENDERPROTO_VERSION)...")
- $(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(RENDERPROTO_BINS)
- $(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(RENDERPROTO_SBINS)
- $(Q)-cd $(SYSROOT)/usr/include; rm -rf $(RENDERPROTO_INCLUDES)
- $(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(RENDERPROTO_LIBS)
- $(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(RENDERPROTO_PKGCONFIGS)
- $(Q)-rm -rf $(RENDERPROTO_BUILD_DIR)*
+RENDERPROTO_NAME := renderproto
+RENDERPROTO_VERSION := $(call embtk_get_pkgversion,renderproto)
+RENDERPROTO_SITE := http://xorg.freedesktop.org/archive/individual/proto
+RENDERPROTO_PACKAGE := renderproto-$(RENDERPROTO_VERSION).tar.bz2
+RENDERPROTO_SRC_DIR := $(PACKAGES_BUILD)/renderproto-$(RENDERPROTO_VERSION)
+RENDERPROTO_BUILD_DIR := $(PACKAGES_BUILD)/renderproto-$(RENDERPROTO_VERSION)
+
+RENDERPROTO_BINS =
+RENDERPROTO_SBINS =
+RENDERPROTO_INCLUDES = X11/extensions/render.h X11/extensions/renderproto.h
+RENDERPROTO_LIBS =
+RENDERPROTO_PKGCONFIGS = renderproto.pc