summaryrefslogtreecommitdiff
path: root/packages/x11/utilmacros
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.com>2010-06-23 23:34:41 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.com>2010-06-23 23:34:41 +0200
commita42b03adc561c5b08ac21e0f2cf21477e2b1c5fd (patch)
treef2ba81c5a618a7e3571b7feb7685a2229546a3ec /packages/x11/utilmacros
parent3292d2fd4ff770e4bf00f52a7c270867d00af1ca (diff)
downloadembtoolkit-a42b03adc561c5b08ac21e0f2cf21477e2b1c5fd.tar.gz
embtoolkit-a42b03adc561c5b08ac21e0f2cf21477e2b1c5fd.tar.bz2
embtoolkit-a42b03adc561c5b08ac21e0f2cf21477e2b1c5fd.tar.xz
Packages: X11: add util-macros-1.9.0
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.com>
Diffstat (limited to 'packages/x11/utilmacros')
-rw-r--r--packages/x11/utilmacros/utilmacros.kconfig28
-rw-r--r--packages/x11/utilmacros/utilmacros.mk12
2 files changed, 19 insertions, 21 deletions
diff --git a/packages/x11/utilmacros/utilmacros.kconfig b/packages/x11/utilmacros/utilmacros.kconfig
index bed1a07..c6f221d 100644
--- a/packages/x11/utilmacros/utilmacros.kconfig
+++ b/packages/x11/utilmacros/utilmacros.kconfig
@@ -1,24 +1,25 @@
################################################################################
-# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
#
-# This program is free software; you can distribute it and/or modify it
-# under the terms of the GNU General Public License
-# (Version 2 or later) published by the Free Software Foundation.
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
#
-# This program is distributed in the hope it will be useful, but WITHOUT
-# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
-# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
-# for more details.
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
#
-# You should have received a copy of the GNU General Public License along
-# with this program; if not, write to the Free Software Foundation, Inc.,
-# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
################################################################################
#
# \file utilmacros.kconfig
# \brief utilmacros.kconfig of Embtoolkit
-# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# \date March 2010
################################################################################
@@ -32,6 +33,8 @@ choice
help
Here you can choose which version of utilmacros you want to use.
+ config EMBTK_UTILMACROS_VERSION_1_9_0
+ bool "util-macros-1.9.0"
config EMBTK_UTILMACROS_VERSION_1_8_0
bool "util-macros-1.8.0"
config EMBTK_UTILMACROS_VERSION_1_7_0
@@ -44,6 +47,7 @@ endchoice
config EMBTK_UTILMACROS_VERSION_STRING
string
+ default "1.9.0" if EMBTK_UTILMACROS_VERSION_1_9_0
default "1.8.0" if EMBTK_UTILMACROS_VERSION_1_8_0
default "1.7.0" if EMBTK_UTILMACROS_VERSION_1_7_0
default "1.6.1" if EMBTK_UTILMACROS_VERSION_1_6_1
diff --git a/packages/x11/utilmacros/utilmacros.mk b/packages/x11/utilmacros/utilmacros.mk
index c8abd0d..882ece5 100644
--- a/packages/x11/utilmacros/utilmacros.mk
+++ b/packages/x11/utilmacros/utilmacros.mk
@@ -1,6 +1,6 @@
################################################################################
-# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
-# Copyright(C) 2009 GAYE Abdoulaye Walsimou. All rights reserved.
+# Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -19,7 +19,7 @@
#
# \file utilmacros.mk
# \brief utilmacros.mk of Embtoolkit
-# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# \date March 2010
################################################################################
@@ -34,12 +34,6 @@ UTILMACROS_INCLUDES =
UTILMACROS_LIBS =
UTILMACROS_PKGCONFIGS = xorg-macros.pc
-ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
-PKG_CONFIG_PATH=$(SYSROOT)/usr/lib32/pkgconfig
-else
-PKG_CONFIG_PATH=$(SYSROOT)/usr/lib/pkgconfig
-endif
-
utilmacros_install: $(UTILMACROS_BUILD_DIR)/.installed
$(UTILMACROS_BUILD_DIR)/.installed: download_utilmacros \