summaryrefslogtreecommitdiff
path: root/packages/x11/xkbcomp
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-08-22 20:05:12 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2010-08-22 20:05:12 +0200
commitdbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd (patch)
treeefb0370771ebdf5143a55cd08ce09942cf213208 /packages/x11/xkbcomp
parent4d4894930a92e5101a0f045dc20be4f6ccb21e1f (diff)
downloadembtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.gz
embtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.bz2
embtoolkit-dbfc9fdc6085a528fc8178ff5ce9960ad8f6a5cd.tar.xz
Embtk: drastically improve packages rebuild duration
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/x11/xkbcomp')
-rw-r--r--packages/x11/xkbcomp/xkbcomp.mk12
1 files changed, 8 insertions, 4 deletions
diff --git a/packages/x11/xkbcomp/xkbcomp.mk b/packages/x11/xkbcomp/xkbcomp.mk
index fe46fd7..e0cfbf1 100644
--- a/packages/x11/xkbcomp/xkbcomp.mk
+++ b/packages/x11/xkbcomp/xkbcomp.mk
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
+# Copyright(C) 2010 Abdoulaye Walsimou GAYE. All rights reserved.
#
# This program is free software; you can distribute it and/or modify it
# under the terms of the GNU General Public License
@@ -18,7 +18,7 @@
#
# \file xkbcomp.mk
# \brief xkbcomp.mk of Embtoolkit
-# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
# \date March 2010
################################################################################
@@ -34,7 +34,10 @@ XKBCOMP_LIBS =
XKBCOMP_PKGCONFIGS =
XKBCOMP_DEPS = libxkbfile_install
-xkbcomp_install: $(XKBCOMP_BUILD_DIR)/.installed
+
+xkbcomp_install:
+ @test -e $(XKBCOMP_BUILD_DIR)/.installed || \
+ $(MAKE) $(XKBCOMP_BUILD_DIR)/.installed
$(XKBCOMP_BUILD_DIR)/.installed: $(XKBCOMP_DEPS) download_xkbcomp \
$(XKBCOMP_BUILD_DIR)/.decompressed $(XKBCOMP_BUILD_DIR)/.configured
@@ -82,10 +85,11 @@ $(XKBCOMP_BUILD_DIR)/.configured:
@touch $@
xkbcomp_clean:
- $(call EMBTK_GENERIC_MESSAGE,"cleanup xkbcomp-$(XKBCOMP_VERSION)...")
+ $(call EMBTK_GENERIC_MESSAGE,"cleanup xkbcomp...")
$(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(XKBCOMP_BINS)
$(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(XKBCOMP_SBINS)
$(Q)-cd $(SYSROOT)/usr/include; rm -rf $(XKBCOMP_INCLUDES)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(XKBCOMP_LIBS)
$(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(XKBCOMP_PKGCONFIGS)
+ $(Q)-rm -rf $(XKBCOMP_BUILD_DIR)