summaryrefslogtreecommitdiff
path: root/packages/x11/xproto/xproto.mk
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2010-03-07 23:09:24 +0100
committerAbdoulaye Walsimou Gaye <walsimou@walsimou.com>2010-03-07 23:14:30 +0100
commit48b82779acbe28349d2111a86ac2dde95adb59fd (patch)
treece91bf48d1e5e66ed93711f0ecd89be10b45d530 /packages/x11/xproto/xproto.mk
parentfeb16c4606efa24684e451e4db7d14d9864b5afe (diff)
downloadembtoolkit-48b82779acbe28349d2111a86ac2dde95adb59fd.tar.gz
embtoolkit-48b82779acbe28349d2111a86ac2dde95adb59fd.tar.bz2
embtoolkit-48b82779acbe28349d2111a86ac2dde95adb59fd.tar.xz
Packages: X Windowing system: Massive X windowing system packages introduction
Signed-off-by: Abdoulaye Walsimou Gaye <walsimou@walsimou.com>
Diffstat (limited to 'packages/x11/xproto/xproto.mk')
-rw-r--r--packages/x11/xproto/xproto.mk103
1 files changed, 103 insertions, 0 deletions
diff --git a/packages/x11/xproto/xproto.mk b/packages/x11/xproto/xproto.mk
new file mode 100644
index 0000000..59a46a2
--- /dev/null
+++ b/packages/x11/xproto/xproto.mk
@@ -0,0 +1,103 @@
+################################################################################
+# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
+#
+# This program is free software; you can distribute it and/or modify it
+# under the terms of the GNU General Public License
+# (Version 2 or later) published by the Free Software Foundation.
+#
+# This program is distributed in the hope it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
+################################################################################
+#
+# \file xproto.mk
+# \brief xproto.mk of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date March 2010
+################################################################################
+
+XPROTO_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_XPROTO_VERSION_STRING)))
+XPROTO_SITE := http://ftp.x.org/pub/individual/proto
+XPROTO_PACKAGE := xproto-$(XPROTO_VERSION).tar.bz2
+XPROTO_BUILD_DIR := $(PACKAGES_BUILD)/xproto-$(XPROTO_VERSION)
+
+XPROTO_BINS =
+XPROTO_SBINS =
+XPROTO_INCLUDES = X11/keysymdef.h X11/Xalloca.h X11/Xatom.h X11/XF86keysym.h \
+ X11/Xfuncs.h Xmd.h X11/Xos.h X11/Xpoll.h X11/Xprotostr.h \
+ X11/keysym.h X11/Xarch.h X11/Xdefs.h X11/Xfuncproto.h X11/X.h \
+ X11/Xosdefs.h X11/Xos_r.h X11/Xproto.h X11/Xthreads.h
+XPROTO_LIBS =
+XPROTO_PKGCONFIGS = xproto.pc
+
+ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
+PKG_CONFIG_PATH=$(SYSROOT)/usr/lib32/pkgconfig
+else
+PKG_CONFIG_PATH=$(SYSROOT)/usr/lib/pkgconfig
+endif
+
+xproto_install: $(XPROTO_BUILD_DIR)/.installed
+
+$(XPROTO_BUILD_DIR)/.installed: download_xproto \
+ $(XPROTO_BUILD_DIR)/.decompressed $(XPROTO_BUILD_DIR)/.configured
+ $(call EMBTK_GENERIC_MESSAGE,"Compiling and installing \
+ xproto-$(XPROTO_VERSION) in your root filesystem...")
+ $(Q)$(MAKE) -C $(XPROTO_BUILD_DIR) $(J)
+ $(Q)$(MAKE) -C $(XPROTO_BUILD_DIR) DESTDIR=$(SYSROOT) install
+ $(Q)$(MAKE) libtool_files_adapt
+ $(Q)$(MAKE) pkgconfig_files_adapt
+ @touch $@
+
+download_xproto:
+ $(call EMBTK_GENERIC_MESSAGE,"Downloading $(XPROTO_PACKAGE) \
+ if necessary...")
+ @test -e $(DOWNLOAD_DIR)/$(XPROTO_PACKAGE) || \
+ wget -O $(DOWNLOAD_DIR)/$(XPROTO_PACKAGE) \
+ $(XPROTO_SITE)/$(XPROTO_PACKAGE)
+
+$(XPROTO_BUILD_DIR)/.decompressed:
+ $(call EMBTK_GENERIC_MESSAGE,"Decompressing $(XPROTO_PACKAGE) ...")
+ @tar -C $(PACKAGES_BUILD) -xjvf $(DOWNLOAD_DIR)/$(XPROTO_PACKAGE)
+ @touch $@
+
+$(XPROTO_BUILD_DIR)/.configured:
+ $(Q)cd $(XPROTO_BUILD_DIR); \
+ CC=$(TARGETCC_CACHED) \
+ CXX=$(TARGETCXX_CACHED) \
+ AR=$(TARGETAR) \
+ RANLIB=$(TARGETRANLIB) \
+ AS=$(CROSS_COMPILE)as \
+ LD=$(TARGETLD) \
+ NM=$(TARGETNM) \
+ STRIP=$(TARGETSTRIP) \
+ OBJDUMP=$(TARGETOBJDUMP) \
+ OBJCOPY=$(TARGETOBJCOPY) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ CXXFLAGS="$(TARGET_CFLAGS)" \
+ LDFLAGS="-L$(SYSROOT)/$(LIBDIR) -L$(SYSROOT)/usr/$(LIBDIR)" \
+ CPPFLGAS="-I$(SYSROOT)/usr/include" \
+ PKG_CONFIG=$(PKGCONFIG_BIN) \
+ PKG_CONFIG_PATH=$(PKG_CONFIG_PATH) \
+ ./configure --build=$(HOST_BUILD) --host=$(STRICT_GNU_TARGET) \
+ --target=$(STRICT_GNU_TARGET) \
+ --prefix=/usr --libdir=/usr/$(LIBDIR)
+ @touch $@
+
+xproto_clean:
+ $(call EMBTK_GENERIC_MESSAGE,"cleanup xproto-$(XPROTO_VERSION)...")
+ $(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(XPROTO_BINS)
+ $(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(XPROTO_SBINS)
+ $(Q)-cd $(SYSROOT)/usr/include; rm -rf $(XPROTO_INCLUDES)
+ $(Q)-cd $(SYSROOT)/usr/lib; rm -rf $(XPROTO_LIBS)
+ $(Q)-cd $(SYSROOT)/usr/lib/pkgconfig; rm -rf $(XPROTO_PKGCONFIGS)
+ifeq ($(CONFIG_EMBTK_64BITS_FS_COMPAT32),y)
+ $(Q)-cd $(SYSROOT)/usr/lib32; rm -rf $(XPROTO_LIBS)
+ $(Q)-cd $(SYSROOT)/usr/lib32/pkgconfig; rm -rf $(XPROTO_PKGCONFIGS)
+endif
+