summaryrefslogtreecommitdiff
path: root/packages/x11/xproto
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-08-30 21:07:33 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.org>2011-08-30 21:07:33 +0200
commitfc9e73f1e87c6e55223158c5d2e2fe8f9d3c2ce5 (patch)
treef0f854815e87328a3f8c749210b2f793d0eaf602 /packages/x11/xproto
parentdc8ad05cccf64348b9235bd6aabed302b12ae3ab (diff)
downloadembtoolkit-fc9e73f1e87c6e55223158c5d2e2fe8f9d3c2ce5.tar.gz
embtoolkit-fc9e73f1e87c6e55223158c5d2e2fe8f9d3c2ce5.tar.bz2
embtoolkit-fc9e73f1e87c6e55223158c5d2e2fe8f9d3c2ce5.tar.xz
Packages: convert more (almost all) packages to generic macros
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.org>
Diffstat (limited to 'packages/x11/xproto')
-rw-r--r--packages/x11/xproto/xproto.kconfig9
-rw-r--r--packages/x11/xproto/xproto.mk78
2 files changed, 20 insertions, 67 deletions
diff --git a/packages/x11/xproto/xproto.kconfig b/packages/x11/xproto/xproto.kconfig
index b5a3b91..1bc7bf0 100644
--- a/packages/x11/xproto/xproto.kconfig
+++ b/packages/x11/xproto/xproto.kconfig
@@ -25,6 +25,7 @@
config EMBTK_HAVE_XPROTO
bool "Have xproto"
+ select EMBTK_XPROTO_PKG_IS_TARBZ2
help
xproto for X windowing system.
xproto provides the headers and specification documents
@@ -59,3 +60,11 @@ config EMBTK_XPROTO_VERSION_STRING
default "7.0.17" if EMBTK_XPROTO_VERSION_7_0_17
default "7.0.16" if EMBTK_XPROTO_VERSION_7_0_16
+config EMBTK_XPROTO_NEED_PATCH
+ bool
+config EMBTK_XPROTO_NEED_AUTORECONF
+ bool
+config EMBTK_XPROTO_PKG_IS_TARGZ
+ bool
+config EMBTK_XPROTO_PKG_IS_TARBZ2
+ bool
diff --git a/packages/x11/xproto/xproto.mk b/packages/x11/xproto/xproto.mk
index 72be7fb..a6d6d0b 100644
--- a/packages/x11/xproto/xproto.mk
+++ b/packages/x11/xproto/xproto.mk
@@ -23,75 +23,19 @@
# \date March 2010
################################################################################
-XPROTO_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_XPROTO_VERSION_STRING)))
-XPROTO_SITE := http://ftp.x.org/pub/individual/proto
-XPROTO_PACKAGE := xproto-$(XPROTO_VERSION).tar.bz2
-XPROTO_BUILD_DIR := $(PACKAGES_BUILD)/xproto-$(XPROTO_VERSION)
-
-XPROTO_BINS =
-XPROTO_SBINS =
-XPROTO_INCLUDES = X11/keysymdef.h X11/Xalloca.h X11/Xatom.h X11/XF86keysym.h \
+XPROTO_NAME := xproto
+XPROTO_VERSION := $(call embtk_get_pkgversion,xproto)
+XPROTO_SITE := http://ftp.x.org/pub/individual/proto
+XPROTO_PACKAGE := xproto-$(XPROTO_VERSION).tar.bz2
+XPROTO_SRC_DIR := $(PACKAGES_BUILD)/xproto-$(XPROTO_VERSION)
+XPROTO_BUILD_DIR := $(PACKAGES_BUILD)/xproto-$(XPROTO_VERSION)
+
+XPROTO_BINS =
+XPROTO_SBINS =
+XPROTO_INCLUDES = X11/keysymdef.h X11/Xalloca.h X11/Xatom.h X11/XF86keysym.h \
X11/Xfuncs.h Xmd.h X11/Xos.h X11/Xpoll.h X11/Xprotostr.h \
X11/keysym.h X11/Xarch.h X11/Xdefs.h X11/Xfuncproto.h X11/X.h \
X11/Xosdefs.h X11/Xos_r.h X11/Xproto.h X11/Xthreads.h
-XPROTO_LIBS =
+XPROTO_LIBS =
XPROTO_PKGCONFIGS = xproto.pc
-xproto_install:
- @test -e $(XPROTO_BUILD_DIR)/.installed || \
- $(MAKE) $(XPROTO_BUILD_DIR)/.installed
-
-$(XPROTO_BUILD_DIR)/.installed: download_xproto \
- $(XPROTO_BUILD_DIR)/.decompressed $(XPROTO_BUILD_DIR)/.configured
- $(call embtk_generic_message,"Compiling and installing \
- xproto-$(XPROTO_VERSION) in your root filesystem...")
- $(Q)$(MAKE) -C $(XPROTO_BUILD_DIR) $(J)
- $(Q)$(MAKE) -C $(XPROTO_BUILD_DIR) DESTDIR=$(SYSROOT) install
- $(Q)$(MAKE) libtool_files_adapt
- $(Q)$(MAKE) pkgconfig_files_adapt
- @touch $@
-
-download_xproto:
- $(call embtk_generic_message,"Downloading $(XPROTO_PACKAGE) \
- if necessary...")
- @test -e $(DOWNLOAD_DIR)/$(XPROTO_PACKAGE) || \
- wget -O $(DOWNLOAD_DIR)/$(XPROTO_PACKAGE) \
- $(XPROTO_SITE)/$(XPROTO_PACKAGE)
-
-$(XPROTO_BUILD_DIR)/.decompressed:
- $(call embtk_generic_message,"Decompressing $(XPROTO_PACKAGE) ...")
- @tar -C $(PACKAGES_BUILD) -xjvf $(DOWNLOAD_DIR)/$(XPROTO_PACKAGE)
- @touch $@
-
-$(XPROTO_BUILD_DIR)/.configured:
- $(Q)cd $(XPROTO_BUILD_DIR); \
- CC=$(TARGETCC_CACHED) \
- CXX=$(TARGETCXX_CACHED) \
- AR=$(TARGETAR) \
- RANLIB=$(TARGETRANLIB) \
- AS=$(CROSS_COMPILE)as \
- LD=$(TARGETLD) \
- NM=$(TARGETNM) \
- STRIP=$(TARGETSTRIP) \
- OBJDUMP=$(TARGETOBJDUMP) \
- OBJCOPY=$(TARGETOBJCOPY) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CXXFLAGS="$(TARGET_CFLAGS)" \
- LDFLAGS="-L$(SYSROOT)/$(LIBDIR) -L$(SYSROOT)/usr/$(LIBDIR)" \
- CPPFLGAS="-I$(SYSROOT)/usr/include" \
- PKG_CONFIG=$(PKGCONFIG_BIN) \
- PKG_CONFIG_PATH=$(EMBTK_PKG_CONFIG_PATH) \
- ./configure --build=$(HOST_BUILD) --host=$(STRICT_GNU_TARGET) \
- --target=$(STRICT_GNU_TARGET) --prefix=/usr --libdir=/usr/$(LIBDIR) \
- --disable-malloc0returnsnull
- @touch $@
-
-xproto_clean:
- $(call embtk_generic_message,"cleanup xproto...")
- $(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(XPROTO_BINS)
- $(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(XPROTO_SBINS)
- $(Q)-cd $(SYSROOT)/usr/include; rm -rf $(XPROTO_INCLUDES)
- $(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(XPROTO_LIBS)
- $(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(XPROTO_PKGCONFIGS)
- $(Q)-rm -rf $(XPROTO_BUILD_DIR)*
-