summaryrefslogtreecommitdiff
path: root/packages/x11
diff options
context:
space:
mode:
authorAbdoulaye Walsimou Gaye <awg@embtoolkit.com>2010-06-20 22:18:08 +0200
committerAbdoulaye Walsimou Gaye <awg@embtoolkit.com>2010-06-20 22:18:08 +0200
commitd1c627c07064e18ae6923e140be9fec5ef75b37e (patch)
tree53f66c85e4ed632e8899f467149223d473da3ce8 /packages/x11
parente44fb29a57f5172e946c4a25e7b8a59335b1d1c6 (diff)
downloadembtoolkit-d1c627c07064e18ae6923e140be9fec5ef75b37e.tar.gz
embtoolkit-d1c627c07064e18ae6923e140be9fec5ef75b37e.tar.bz2
embtoolkit-d1c627c07064e18ae6923e140be9fec5ef75b37e.tar.xz
Packages: X11: New add xineramaproto
Signed-off-by: Abdoulaye Walsimou Gaye <awg@embtoolkit.com>
Diffstat (limited to 'packages/x11')
-rw-r--r--packages/x11/x11.kconfig1
-rw-r--r--packages/x11/x11.mk5
-rw-r--r--packages/x11/xineramaproto/xineramaproto.kconfig43
-rw-r--r--packages/x11/xineramaproto/xineramaproto.mk91
4 files changed, 140 insertions, 0 deletions
diff --git a/packages/x11/x11.kconfig b/packages/x11/x11.kconfig
index ca6ec53..30b9cc6 100644
--- a/packages/x11/x11.kconfig
+++ b/packages/x11/x11.kconfig
@@ -45,6 +45,7 @@ source packages/x11/videoproto/videoproto.kconfig
source packages/x11/xcbproto/xcbproto.kconfig
source packages/x11/xcmiscproto/xcmiscproto.kconfig
source packages/x11/xextproto/xextproto.kconfig
+source packages/x11/xineramaproto/xineramaproto.kconfig
source packages/x11/xproto/xproto.kconfig
endmenu
diff --git a/packages/x11/x11.mk b/packages/x11/x11.mk
index 6ac7be9..03e2d10 100644
--- a/packages/x11/x11.mk
+++ b/packages/x11/x11.mk
@@ -113,6 +113,11 @@ include $(EMBTK_ROOT)/packages/x11/xextproto/xextproto.mk
ROOTFS_COMPONENTS_CLEAN += xextproto_clean
ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_XEXTPROTO) += xextproto_install
+#xineramaproto
+include $(EMBTK_ROOT)/packages/x11/xineramaproto/xineramaproto.mk
+ROOTFS_COMPONENTS_CLEAN += xineramaproto_clean
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_XINERAMAPROTO) += xineramaproto_install
+
#xproto
include $(EMBTK_ROOT)/packages/x11/xproto/xproto.mk
ROOTFS_COMPONENTS_CLEAN += xproto_clean
diff --git a/packages/x11/xineramaproto/xineramaproto.kconfig b/packages/x11/xineramaproto/xineramaproto.kconfig
new file mode 100644
index 0000000..7cccf69
--- /dev/null
+++ b/packages/x11/xineramaproto/xineramaproto.kconfig
@@ -0,0 +1,43 @@
+################################################################################
+# Abdoulaye Walsimou GAYE, <awg@embtoolkit.org>
+# Copyright(C) 2010 Abdoulaye Walsimou GAYE. All rights reserved.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file xineramaproto.kconfig
+# \brief xineramaproto.kconfig of Embtoolkit
+# \author Abdoulaye Walsimou GAYE, <awg@embtoolkit.org>
+# \date June 2010
+################################################################################
+
+config EMBTK_HAVE_XINERAMAPROTO
+ bool "Have xineramaproto"
+ help
+ xineramaproto for X windowing system
+choice
+ prompt "xineramaproto version you wish"
+ depends on EMBTK_HAVE_XINERAMAPROTO
+ help
+ Here you can choose which version of xineramaproto you want to use.
+
+ config EMBTK_XINERAMAPROTO_VERSION_1_2
+ bool "xineramaproto-1.2"
+endchoice
+
+config EMBTK_XINERAMAPROTO_VERSION_STRING
+ string
+ default "1.2" if EMBTK_XINERAMAPROTO_VERSION_1_2
+
diff --git a/packages/x11/xineramaproto/xineramaproto.mk b/packages/x11/xineramaproto/xineramaproto.mk
new file mode 100644
index 0000000..e7f0174
--- /dev/null
+++ b/packages/x11/xineramaproto/xineramaproto.mk
@@ -0,0 +1,91 @@
+################################################################################
+# Abdoulaye Walsimou GAYE, <awg@embtoolkit.org>
+# Copyright(C) 2010 Abdoulaye Walsimou GAYE. All rights reserved.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 3 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file xineramaproto.mk
+# \brief xineramaproto.mk of Embtoolkit
+# \author Abdoulaye Walsimou GAYE, <awg@embtoolkit.org>
+# \date June 2010
+################################################################################
+
+XINERAMAPROTO_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_XINERAMAPROTO_VERSION_STRING)))
+XINERAMAPROTO_SITE := http://ftp.x.org/pub/individual/proto
+XINERAMAPROTO_PACKAGE := xineramaproto-$(XINERAMAPROTO_VERSION).tar.bz2
+XINERAMAPROTO_BUILD_DIR := $(PACKAGES_BUILD)/xineramaproto-$(XINERAMAPROTO_VERSION)
+
+XINERAMAPROTO_BINS =
+XINERAMAPROTO_SBINS =
+XINERAMAPROTO_INCLUDES = X11/extensions/panoramiXproto.h
+XINERAMAPROTO_LIBS =
+XINERAMAPROTO_PKGCONFIGS = xineramaproto.pc
+
+xineramaproto_install: $(XINERAMAPROTO_BUILD_DIR)/.installed
+
+$(XINERAMAPROTO_BUILD_DIR)/.installed: download_xineramaproto \
+ $(XINERAMAPROTO_BUILD_DIR)/.decompressed $(XINERAMAPROTO_BUILD_DIR)/.configured
+ $(call EMBTK_GENERIC_MESSAGE,"Compiling and installing \
+ xineramaproto-$(XINERAMAPROTO_VERSION) in your root filesystem...")
+ $(Q)$(MAKE) -C $(XINERAMAPROTO_BUILD_DIR) $(J)
+ $(Q)$(MAKE) -C $(XINERAMAPROTO_BUILD_DIR) DESTDIR=$(SYSROOT) install
+ $(Q)$(MAKE) libtool_files_adapt
+ $(Q)$(MAKE) pkgconfig_files_adapt
+ @touch $@
+
+download_xineramaproto:
+ $(call EMBTK_GENERIC_MESSAGE,"Downloading $(XINERAMAPROTO_PACKAGE) \
+ if necessary...")
+ @test -e $(DOWNLOAD_DIR)/$(XINERAMAPROTO_PACKAGE) || \
+ wget -O $(DOWNLOAD_DIR)/$(XINERAMAPROTO_PACKAGE) \
+ $(XINERAMAPROTO_SITE)/$(XINERAMAPROTO_PACKAGE)
+
+$(XINERAMAPROTO_BUILD_DIR)/.decompressed:
+ $(call EMBTK_GENERIC_MESSAGE,"Decompressing $(XINERAMAPROTO_PACKAGE) ...")
+ @tar -C $(PACKAGES_BUILD) -xjvf $(DOWNLOAD_DIR)/$(XINERAMAPROTO_PACKAGE)
+ @touch $@
+
+$(XINERAMAPROTO_BUILD_DIR)/.configured:
+ $(Q)cd $(XINERAMAPROTO_BUILD_DIR); \
+ CC=$(TARGETCC_CACHED) \
+ CXX=$(TARGETCXX_CACHED) \
+ AR=$(TARGETAR) \
+ RANLIB=$(TARGETRANLIB) \
+ AS=$(CROSS_COMPILE)as \
+ LD=$(TARGETLD) \
+ NM=$(TARGETNM) \
+ STRIP=$(TARGETSTRIP) \
+ OBJDUMP=$(TARGETOBJDUMP) \
+ OBJCOPY=$(TARGETOBJCOPY) \
+ CFLAGS="$(TARGET_CFLAGS)" \
+ CXXFLAGS="$(TARGET_CFLAGS)" \
+ LDFLAGS="-L$(SYSROOT)/$(LIBDIR) -L$(SYSROOT)/usr/$(LIBDIR)" \
+ CPPFLGAS="-I$(SYSROOT)/usr/include" \
+ PKG_CONFIG=$(PKGCONFIG_BIN) \
+ PKG_CONFIG_PATH=$(PKG_CONFIG_PATH) \
+ ./configure --build=$(HOST_BUILD) --host=$(STRICT_GNU_TARGET) \
+ --target=$(STRICT_GNU_TARGET) --prefix=/usr --libdir=/usr/$(LIBDIR) \
+ --disable-malloc0returnsnull
+ @touch $@
+
+xineramaproto_clean:
+ $(call EMBTK_GENERIC_MESSAGE,"cleanup xineramaproto-$(XINERAMAPROTO_VERSION)...")
+ $(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(XINERAMAPROTO_BINS)
+ $(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(XINERAMAPROTO_SBINS)
+ $(Q)-cd $(SYSROOT)/usr/include; rm -rf $(XINERAMAPROTO_INCLUDES)
+ $(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(XINERAMAPROTO_LIBS)
+ $(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(XINERAMAPROTO_PKGCONFIGS)
+