summaryrefslogtreecommitdiff
path: root/packages/compression/compression.mk
diff options
context:
space:
mode:
Diffstat (limited to 'packages/compression/compression.mk')
-rw-r--r--packages/compression/compression.mk16
1 files changed, 8 insertions, 8 deletions
diff --git a/packages/compression/compression.mk b/packages/compression/compression.mk
index a13e8f3..1a8068a 100644
--- a/packages/compression/compression.mk
+++ b/packages/compression/compression.mk
@@ -1,6 +1,6 @@
################################################################################
# Embtoolkit
-# Copyright(C) 2010-2011 Abdoulaye Walsimou GAYE.
+# Copyright(C) 2010-2014 Abdoulaye Walsimou GAYE.
#
# This program is free software: you can redistribute it and/or modify
# it under the terms of the GNU General Public License as published by
@@ -23,11 +23,11 @@
# \date August 2010
################################################################################
-#lzo for host and target
-include packages/compression/lzo/lzo.mk
-ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_LZO) += lzo_install
-HOSTTOOLS_COMPONENTS-$(CONFIG_EMBTK_HOST_HAVE_LZO) += lzo_host_install
+embtk_pkgincdir := packages/compression
-#zlib for target
-include packages/compression/zlib/zlib.mk
-ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_ZLIB) += zlib_install
+# lzo for host and target
+$(call embtk_include_pkg,lzo)
+$(call embtk_include_hostpkg,lzo_host)
+
+# zlib for target
+$(call embtk_include_pkg,zlib)