summaryrefslogtreecommitdiff
path: root/packages/development/atf/atf.mk
diff options
context:
space:
mode:
Diffstat (limited to 'packages/development/atf/atf.mk')
-rw-r--r--packages/development/atf/atf.mk47
1 files changed, 47 insertions, 0 deletions
diff --git a/packages/development/atf/atf.mk b/packages/development/atf/atf.mk
new file mode 100644
index 0000000..ce72531
--- /dev/null
+++ b/packages/development/atf/atf.mk
@@ -0,0 +1,47 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2014 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file atf.mk
+# \brief atf.mk of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date July 2014
+################################################################################
+
+ATF_NAME := atf
+ATF_VERSION := $(call embtk_get_pkgversion,atf)
+ATF_SITE := $(embtk_ftp/packages-mirror)
+ATF_PACKAGE := atf-$(ATF_VERSION).tar.gz
+ATF_SRC_DIR := $(embtk_pkgb)/atf-$(ATF_VERSION)
+ATF_BUILD_DIR := $(embtk_pkgb)/atf-$(ATF_VERSION)-build
+
+ATF_BINS := atf-sh
+ATF_INCLUDES := atf-c atf-c++ atf-c.h atf-c++.hpp
+ATF_LIBS := libatf-*
+ATF_LIBEXECS := atf-check
+ATF_PKGCONFIGS := atf-*.pc
+ATF_SHARES := aclocal/atf-*.m4 atf doc/atf man/man*/atf-*
+
+ATF_CONFIGURE_ENV := kyua_cv_getopt_plus=yes
+ATF_CONFIGURE_ENV += kyua_cv_attribute_noreturn=yes
+ATF_CONFIGURE_ENV += kyua_cv_getcwd_works=yes
+ATF_CONFIGURE_OPTS := --program-transform-name='s;$(STRICT_GNU_TARGET)-;;'
+
+define embtk_cleanup_atf
+ $(Q)rm -rf $(embtk_sysroot)/usr/tests/atf
+endef