summaryrefslogtreecommitdiff
path: root/packages/development
diff options
context:
space:
mode:
Diffstat (limited to 'packages/development')
-rw-r--r--packages/development/openblas/openblas.mk6
1 files changed, 4 insertions, 2 deletions
diff --git a/packages/development/openblas/openblas.mk b/packages/development/openblas/openblas.mk
index bcbc359..7611070 100644
--- a/packages/development/openblas/openblas.mk
+++ b/packages/development/openblas/openblas.mk
@@ -53,6 +53,8 @@ OPENBLAS_MAKE_ENV += TARGET=$(pembtk_openblas_target)
define embtk_beforeinstall_openblas
$(if $(pembtk_openblas_armfpu),
+ [ -e $(OPENBLAS_SRC_DIR)/Makefile.arm.bak ] && \
+ cp $(OPENBLAS_SRC_DIR)/Makefile.arm.bak $(OPENBLAS_SRC_DIR)/Makefile.arm || true
cp $(OPENBLAS_SRC_DIR)/Makefile.arm $(OPENBLAS_SRC_DIR)/Makefile.arm.bak
sed -e 's/-mfpu=[[:alnum:]]*/-mfpu=$(pembtk_openblas_armfpu)/g' \
< $(OPENBLAS_SRC_DIR)/Makefile.arm \
@@ -61,6 +63,6 @@ define embtk_beforeinstall_openblas
endef
define embtk_install_openblas
- $(embtk_beforeinstall_openblas)
- $(call embtk_makeinstall_pkg,openblas)
+ $(call embtk_download_pkg,openblas)
+ $(call embtk_makeinstall_pkg,openblas)
endef