summaryrefslogtreecommitdiff
path: root/packages/htools/m4/m4.mk
diff options
context:
space:
mode:
Diffstat (limited to 'packages/htools/m4/m4.mk')
-rw-r--r--packages/htools/m4/m4.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/htools/m4/m4.mk b/packages/htools/m4/m4.mk
new file mode 100644
index 0000000..e09b31e
--- /dev/null
+++ b/packages/htools/m4/m4.mk
@@ -0,0 +1,31 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2010-2013 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file m4.mk
+# \brief m4.mk of Embtoolkit.
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date February 2010
+################################################################################
+
+M4_HOST_NAME := m4
+M4_HOST_VERSION := $(call embtk_get_pkgversion,m4_host)
+M4_HOST_SITE := http://ftp.gnu.org/gnu/m4
+M4_HOST_PACKAGE := m4-$(M4_HOST_VERSION).tar.bz2
+M4_HOST_SRC_DIR := $(embtk_toolsb)/m4-$(M4_HOST_VERSION)
+M4_HOST_BUILD_DIR := $(embtk_toolsb)/m4-$(M4_HOST_VERSION)