summaryrefslogtreecommitdiff
path: root/packages/htools
diff options
context:
space:
mode:
Diffstat (limited to 'packages/htools')
-rw-r--r--packages/htools/gettext/gettext.kconfig38
-rw-r--r--packages/htools/gettext/gettext.mk40
-rw-r--r--packages/htools/hosttools-buildopts.kconfig5
-rw-r--r--packages/htools/hosttools-buildopts.mk3
4 files changed, 86 insertions, 0 deletions
diff --git a/packages/htools/gettext/gettext.kconfig b/packages/htools/gettext/gettext.kconfig
new file mode 100644
index 0000000..8ae773a
--- /dev/null
+++ b/packages/htools/gettext/gettext.kconfig
@@ -0,0 +1,38 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2014 GAYE Abdoulaye Walsimou.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file gettext.kconfig
+# \brief gettext.kconfig of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date December 2009
+################################################################################
+
+config EMBTK_HOST_HAVE_GETTEXT
+ bool
+ help
+ gettext for host development machine.
+
+config EMBTK_GETTEXT_HOST_VERSION_STRING
+ string
+ default "0.18.3.2"
+
+config EMBTK_GETTEXT_HOST_NEED_PATCH
+ bool
+config EMBTK_GETTEXT_HOST_NEED_AUTORECONF
+ bool
diff --git a/packages/htools/gettext/gettext.mk b/packages/htools/gettext/gettext.mk
new file mode 100644
index 0000000..21658d2
--- /dev/null
+++ b/packages/htools/gettext/gettext.mk
@@ -0,0 +1,40 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2009-2011 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file gettext.mk
+# \brief gettext.mk of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date December 2009
+################################################################################
+
+GETTEXT_HOST_NAME := gettext
+GETTEXT_HOST_VERSION := $(call embtk_pkg_version,gettext_host)
+GETTEXT_HOST_SITE := http://ftp.gnu.org/pub/gnu/gettext
+GETTEXT_HOST_PACKAGE := gettext-$(GETTEXT_HOST_VERSION).tar.gz
+GETTEXT_HOST_SRC_DIR := $(embtk_toolsb)/gettext-$(GETTEXT_HOST_VERSION)
+GETTEXT_HOST_BUILD_DIR := $(embtk_toolsb)/gettext-$(GETTEXT_HOST_VERSION)-build
+
+GETTEXT_HOST_CONFIGURE_OPTS := --disable-java
+GETTEXT_HOST_CONFIGURE_OPTS += --disable-native-java
+GETTEXT_HOST_CONFIGURE_OPTS += --disable-openmp
+GETTEXT_HOST_CONFIGURE_OPTS += --with-included-gettext
+GETTEXT_HOST_CONFIGURE_OPTS += --with-included-glib
+GETTEXT_HOST_CONFIGURE_OPTS += --with-included-libcroco
+GETTEXT_HOST_CONFIGURE_OPTS += --with-included-libxml
+GETTEXT_HOST_CONFIGURE_OPTS += --enable-static --disable-shared
diff --git a/packages/htools/hosttools-buildopts.kconfig b/packages/htools/hosttools-buildopts.kconfig
index a7b2119..cffaeeb 100644
--- a/packages/htools/hosttools-buildopts.kconfig
+++ b/packages/htools/hosttools-buildopts.kconfig
@@ -75,6 +75,11 @@ config EMBTK_HAVE_MKIMAGE
u-boot mkimage tool.
#
+# gettext
+#
+source packages/htools/gettext/gettext.kconfig
+
+#
# gperf for host
#
source packages/htools/gperf/gperf.kconfig
diff --git a/packages/htools/hosttools-buildopts.mk b/packages/htools/hosttools-buildopts.mk
index e014dcc..ae99d5f 100644
--- a/packages/htools/hosttools-buildopts.mk
+++ b/packages/htools/hosttools-buildopts.mk
@@ -38,6 +38,9 @@ $(call embtk_include_hostpkg,ccache_host)
include packages/htools/fakeroot/vars.mk
$(call embtk_include_hostpkg,fakeroot_host)
+# gettext
+$(call embtk_include_hostpkg,gettext_host)
+
# gmake
$(call embtk_include_hostpkg,gmake_host)