summaryrefslogtreecommitdiff
path: root/packages/htools
diff options
context:
space:
mode:
Diffstat (limited to 'packages/htools')
-rw-r--r--packages/htools/hosttools-buildopts.kconfig2
-rw-r--r--packages/htools/hosttools-buildopts.mk4
-rw-r--r--packages/htools/pkgconf/pkgconf.kconfig48
-rw-r--r--packages/htools/pkgconf/pkgconf.mk43
-rw-r--r--packages/htools/pkgconf/vars.mk21
5 files changed, 117 insertions, 1 deletions
diff --git a/packages/htools/hosttools-buildopts.kconfig b/packages/htools/hosttools-buildopts.kconfig
index b502753..b4bb986 100644
--- a/packages/htools/hosttools-buildopts.kconfig
+++ b/packages/htools/hosttools-buildopts.kconfig
@@ -130,7 +130,7 @@ source kconfig/gmake.kconfig
#
# pkgconf
#
-source kconfig/pkgconf.kconfig
+source packages/htools/pkgconf/pkgconf.kconfig
#
# fakeroot
diff --git a/packages/htools/hosttools-buildopts.mk b/packages/htools/hosttools-buildopts.mk
index 8785184..5cbeb29 100644
--- a/packages/htools/hosttools-buildopts.mk
+++ b/packages/htools/hosttools-buildopts.mk
@@ -31,3 +31,7 @@ $(call embtk_include_hostpkg,ccache_host)
# fakeroot
include packages/htools/fakeroot/vars.mk
$(call embtk_include_hostpkg,fakeroot_host)
+
+# pkgconf
+include packages/htools/pkgconf/vars.mk
+$(call embtk_include_hostpkg,pkgconf_host)
diff --git a/packages/htools/pkgconf/pkgconf.kconfig b/packages/htools/pkgconf/pkgconf.kconfig
new file mode 100644
index 0000000..ef91974
--- /dev/null
+++ b/packages/htools/pkgconf/pkgconf.kconfig
@@ -0,0 +1,48 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2011-2012 Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file pkgconf.kconfig
+# \brief pkgconf.kconfig of Embtoolkit.
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date January 2011
+################################################################################
+
+config EMBTK_HOST_HAVE_PKGCONF
+ bool
+ default y
+ select EMBTK_PKGCONF_HOST_NEED_AUTORECONF
+ help
+ pkgconf for host tools.
+
+config EMBTK_PKGCONF_HOST_VERSION_STRING
+ string
+ default "0.8.9"
+
+config EMBTK_PKGCONF_HOST_VERSION_GIT
+ bool
+
+config EMBTK_PKGCONF_HOST_GIT_SITE
+ string
+ default "git://github.com/pkgconf/pkgconf.git"
+ depends on EMBTK_PKGCONF_HOST_VERSION_GIT
+
+config EMBTK_PKGCONF_HOST_NEED_PATCH
+ bool
+config EMBTK_PKGCONF_HOST_NEED_AUTORECONF
+ bool
diff --git a/packages/htools/pkgconf/pkgconf.mk b/packages/htools/pkgconf/pkgconf.mk
new file mode 100644
index 0000000..62665df
--- /dev/null
+++ b/packages/htools/pkgconf/pkgconf.mk
@@ -0,0 +1,43 @@
+################################################################################
+# Copyright(C) 2013-2014 Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file pkgconf.mk
+# \brief pkgconf.mk of Embtoolkit
+# \author Abdoulaye Walsimou GAYE <awg@embtoolkit.org>
+# \date January 2013
+################################################################################
+
+PKGCONF_HOST_NAME := pkgconf
+PKGCONF_HOST_VERSION := $(call embtk_get_pkgversion,pkgconf_host)
+PKGCONF_HOST_SITE := ftp://ftp.embtoolkit.org/embtoolkit.org/packages-mirror
+PKGCONF_HOST_PACKAGE := pkgconf-$(PKGCONF_HOST_VERSION).tar.gz
+PKGCONF_HOST_SRC_DIR := $(embtk_toolsb)/pkgconf-$(PKGCONF_HOST_VERSION)
+PKGCONF_HOST_BUILD_DIR := $(embtk_toolsb)/pkgconf-$(PKGCONF_HOST_VERSION)
+
+PKGCONFIG_BIN := $(embtk_htools)/usr/bin/pkg-config
+export PKGCONFIG_BIN
+
+#
+# pkgconf install
+#
+PKGCONF_HOST_PREFIX := /usr
+PKGCONF_HOST_DESTDIR := $(embtk_htools)
+
+define embtk_postinstallonce_pkgconf_host
+ cd $(embtk_htools)/usr/bin/; ln -sf pkgconf pkg-config
+endef
diff --git a/packages/htools/pkgconf/vars.mk b/packages/htools/pkgconf/vars.mk
new file mode 100644
index 0000000..0d93fac
--- /dev/null
+++ b/packages/htools/pkgconf/vars.mk
@@ -0,0 +1,21 @@
+#
+# PKG_CONFIG_PATH for target packages
+#
+__EMBTK_PKG_CONFIG_PATH := $(embtk_sysroot)/usr/$(LIBDIR)/pkgconfig
+__EMBTK_PKG_CONFIG_PATH += $(embtk_sysroot)/usr/share/pkgconfig
+EMBTK_PKG_CONFIG_PATH := $(subst $(embtk_space),:,$(__EMBTK_PKG_CONFIG_PATH))
+EMBTK_PKG_CONFIG_LIBDIR := $(EMBTK_PKG_CONFIG_PATH)
+
+export PKGCONFIG_BIN EMBTK_PKG_CONFIG_PATH
+
+#
+# PKG_CONFIG_PATH for host packages
+#
+__EMBTK_HOST_PKG_CONFIG_PATH := $(embtk_htools)/usr/lib/pkgconfig/
+__EMBTK_HOST_PKG_CONFIG_PATH += /usr/lib/pkgconfig/ /usr/share/pkgconfig/
+__EMBTK_HOST_PKG_CONFIG_PATH += /usr/local/lib/pkgconfig/ /usr/local/share/pkgconfig/
+__EMBTK_HOST_PKG_CONFIG_PATH += $(dir $(shell find /usr/lib -type f -name '*.pc' 2>/dev/null))
+__EMBTK_HOST_PKG_CONFIG_PATH += $(dir $(shell find /usr/local/lib -type f -name '*.pc' 2>/dev/null))
+EMBTK_HOST_PKG_CONFIG_PATH := $(subst $(embtk_space),:,$(sort $(__EMBTK_HOST_PKG_CONFIG_PATH)))
+
+export EMBTK_HOST_PKG_CONFIG_PATH