summaryrefslogtreecommitdiff
path: root/packages/net/odhcp6c
diff options
context:
space:
mode:
Diffstat (limited to 'packages/net/odhcp6c')
-rw-r--r--packages/net/odhcp6c/odhcp6c.kconfig48
-rw-r--r--packages/net/odhcp6c/odhcp6c.mk50
2 files changed, 98 insertions, 0 deletions
diff --git a/packages/net/odhcp6c/odhcp6c.kconfig b/packages/net/odhcp6c/odhcp6c.kconfig
new file mode 100644
index 0000000..602b7d5
--- /dev/null
+++ b/packages/net/odhcp6c/odhcp6c.kconfig
@@ -0,0 +1,48 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2012 Averell KINOUANI.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file odhcp6c.kconfig
+# \brief odhcp6c.kconfig of Embtoolkit
+# \author Averell KINOUANI <akinouani@embtoolkit.org>
+# \date February 2015
+################################################################################
+
+config EMBTK_HAVE_ODHCP6C
+ bool "Have odhcp6c"
+ help
+ odhcp6c is a minimal DHCPv6 and RA-client for use in embedded Linux systems
+ especially routers.
+choice
+ prompt "odhcp6c version you wish"
+ depends on EMBTK_HAVE_ODHCP6C
+ help
+ Here you can choose which version of odhcp6c you want to use.
+
+ config EMBTK_ODHCP6C_VERSION_1_1
+ bool "odhcp6c-1.1"
+endchoice
+
+config EMBTK_ODHCP6C_VERSION_STRING
+ string
+ default "1.1" if EMBTK_ODHCP6C_VERSION_1_1
+
+config EMBTK_ODHCP6C_NEED_PATCH
+ bool
+config EMBTK_ODHCP6C_NEED_AUTORECONF
+ bool
diff --git a/packages/net/odhcp6c/odhcp6c.mk b/packages/net/odhcp6c/odhcp6c.mk
new file mode 100644
index 0000000..06702f4
--- /dev/null
+++ b/packages/net/odhcp6c/odhcp6c.mk
@@ -0,0 +1,50 @@
+################################################################################
+# Embtoolkit
+# Copyright(C) 2012 Abdoulaye Walsimou GAYE.
+#
+# This program is free software: you can redistribute it and/or modify
+# it under the terms of the GNU General Public License as published by
+# the Free Software Foundation, either version 2 of the License, or
+# (at your option) any later version.
+#
+# This program is distributed in the hope that it will be useful,
+# but WITHOUT ANY WARRANTY; without even the implied warranty of
+# MERCHANTABILITY or FITNESS FOR A PARTICULAR PURPOSE. See the
+# GNU General Public License for more details.
+#
+# You should have received a copy of the GNU General Public License
+# along with this program. If not, see <http://www.gnu.org/licenses/>.
+#
+################################################################################
+#
+# \file odhcp6c.mk
+# \brief odhcp6c.mk of Embtoolkit
+# \author Averell KINOUANI <a.kinouani@embtoolkit.org>
+# \date July 2015
+################################################################################
+
+ODHCP6C_NAME := odhcp6c
+ODHCP6C_SITE := https://github.com/sbyx/odhcp6c/archive/
+ODHCP6C_VERSION := $(call embtk_get_pkgversion,odhcp6c)
+ODHCP6C_PACKAGE := v$(ODHCP6C_VERSION).tar.gz
+ODHCP6C_SRC_DIR := $(embtk_pkgb)/odhcp6c-$(ODHCP6C_VERSION)
+ODHCP6C_BUILD_DIR := $(embtk_pkgb)/odhcp6c-$(ODHCP6C_VERSION)
+
+ODHCP6C_BINS := odhcp6c
+
+
+ODHCP6C_CMAKE_OPTS := "SET(CMAKE_SYSTEM_NAME Linux)\n\
+ SET(CMAKE_C_COMPILER $(TARGETCC))\n\
+ SET(CMAKE_CXX_COMPILER $(TARGETCXX))\n\
+ SET(CMAKE_FIND_ROOT_PATH $(embtk_tools))\n\
+ SET(CMAKE_FIND_ROOT_PATH_MODE_PROGRAM NEVER)\n\
+ SET(CMAKE_FIND_ROOT_PATH_MODE_LIBRARY $(embtk_sysroot)/usr/lib)\n\
+ SET(CMAKE_FIND_ROOT_PATH_MODE_INCLUDE $(embtk_sysroot)/usr/include)\n\
+ SET(CMAKE_INSTALL_PREFIX $(embtk_sysroot)/usr)\n"
+
+
+define embtk_install_odhcp6c
+ printf $(ODHCP6C_CMAKE_OPTS) >> $(ODHCP6C_BUILD_DIR)/CMakeLists.txt; \
+ (cd $(ODHCP6C_BUILD_DIR)/ && cmake .; make; make install)
+endef
+