summaryrefslogtreecommitdiff
path: root/packages/security/security.mk
diff options
context:
space:
mode:
Diffstat (limited to 'packages/security/security.mk')
-rw-r--r--packages/security/security.mk31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/security/security.mk b/packages/security/security.mk
new file mode 100644
index 0000000..0f44c5d
--- /dev/null
+++ b/packages/security/security.mk
@@ -0,0 +1,31 @@
+################################################################################
+# GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# Copyright(C) 2010 GAYE Abdoulaye Walsimou. All rights reserved.
+#
+# This program is free software; you can distribute it and/or modify it
+# under the terms of the GNU General Public License
+# (Version 2 or later) published by the Free Software Foundation.
+#
+# This program is distributed in the hope it will be useful, but WITHOUT
+# ANY WARRANTY; without even the implied warranty of MERCHANTABILITY or
+# FITNESS FOR A PARTICULAR PURPOSE. See the GNU General Public License
+# for more details.
+#
+# You should have received a copy of the GNU General Public License along
+# with this program; if not, write to the Free Software Foundation, Inc.,
+# 59 Temple Place - Suite 330, Boston MA 02111-1307, USA.
+################################################################################
+#
+# \file security.mk
+# \brief security.mk of Embtoolkit
+# \author GAYE Abdoulaye Walsimou, <walsimou@walsimou.com>
+# \date February 2010
+################################################################################
+
+#OpenSSL
+ROOTFS_COMPONENTS-$(CONFIG_EMBTK_HAVE_OPENSSL) += openssl_install
+ROOTFS_COMPONENTS_CLEAN += openssl_clean
+ifeq ($(CONFIG_EMBTK_HAVE_OPENSSL),y)
+include $(EMBTK_ROOT)/packages/security/openssl/openssl.mk
+endif
+