summaryrefslogtreecommitdiff
path: root/packages/security
diff options
context:
space:
mode:
Diffstat (limited to 'packages/security')
-rw-r--r--packages/security/libressl/libressl.kconfig1
-rw-r--r--packages/security/libressl/libressl.mk13
2 files changed, 0 insertions, 14 deletions
diff --git a/packages/security/libressl/libressl.kconfig b/packages/security/libressl/libressl.kconfig
index 6b9c88e..8309d98 100644
--- a/packages/security/libressl/libressl.kconfig
+++ b/packages/security/libressl/libressl.kconfig
@@ -37,7 +37,6 @@ choice
config EMBTK_LIBRESSL_VERSION_2_0_1
bool "LibreSSL-2.0.1"
- select EMBTK_LIBRESSL_NEED_AUTORECONF
endchoice
config EMBTK_LIBRESSL_VERSION_STRING
diff --git a/packages/security/libressl/libressl.mk b/packages/security/libressl/libressl.mk
index 84ceeb7..8423f3d 100644
--- a/packages/security/libressl/libressl.mk
+++ b/packages/security/libressl/libressl.mk
@@ -35,16 +35,3 @@ LIBRESSL_INCLUDES := openssl
LIBRESSL_LIBS := libcrypto.* libssl.*
LIBRESSL_CONFIGURE_OPTS := --program-transform-name='s;$(STRICT_GNU_TARGET)-;;'
-
-#
-# remove -Werror and -O2 compiler switches
-#
-define embtk_beforeinstall_libressl
- find $(LIBRESSL_SRC_DIR) -type f -name '*.m4' -exec chmod 0664 {} +
- for f in $$(grep -Rl '\-Werror' $(LIBRESSL_SRC_DIR)/*); do \
- sed -e 's/-Werror//g' < $$f > $$f.tmp; mv $$f.tmp $$f; \
- done
- for f in $$(grep -Rl '\-O2' $(LIBRESSL_SRC_DIR)/*); do \
- sed -e 's/-O2//g' < $$f > $$f.tmp; mv $$f.tmp $$f; \
- done
-endef