summaryrefslogtreecommitdiff
path: root/packages/x11/compositeproto/compositeproto.mk
diff options
context:
space:
mode:
Diffstat (limited to 'packages/x11/compositeproto/compositeproto.mk')
-rw-r--r--packages/x11/compositeproto/compositeproto.mk83
1 files changed, 13 insertions, 70 deletions
diff --git a/packages/x11/compositeproto/compositeproto.mk b/packages/x11/compositeproto/compositeproto.mk
index 72d4558..d5c91a5 100644
--- a/packages/x11/compositeproto/compositeproto.mk
+++ b/packages/x11/compositeproto/compositeproto.mk
@@ -23,73 +23,16 @@
# \date March 2010
################################################################################
-COMPOSITEPROTO_VERSION := $(subst ",,$(strip $(CONFIG_EMBTK_COMPOSITEPROTO_VERSION_STRING)))
-COMPOSITEPROTO_SITE := http://ftp.x.org/pub/individual/proto
-COMPOSITEPROTO_PACKAGE := compositeproto-$(COMPOSITEPROTO_VERSION).tar.bz2
-COMPOSITEPROTO_BUILD_DIR := $(PACKAGES_BUILD)/compositeproto-$(COMPOSITEPROTO_VERSION)
-
-COMPOSITEPROTO_BINS =
-COMPOSITEPROTO_SBINS =
-COMPOSITEPROTO_INCLUDES = X11/extensions/compositeproto.h \
- X11/extensions/composite.h
-COMPOSITEPROTO_LIBS =
-COMPOSITEPROTO_PKGCONFIGS = compositeproto.pc
-
-compositeproto_install:
- @test -e $(COMPOSITEPROTO_BUILD_DIR)/.installed || \
- $(MAKE) $(COMPOSITEPROTO_BUILD_DIR)/.installed
-
-$(COMPOSITEPROTO_BUILD_DIR)/.installed: download_compositeproto \
- $(COMPOSITEPROTO_BUILD_DIR)/.decompressed $(COMPOSITEPROTO_BUILD_DIR)/.configured
- $(call embtk_generic_message,"Compiling and installing \
- compositeproto-$(COMPOSITEPROTO_VERSION) in your root filesystem...")
- $(Q)$(MAKE) -C $(COMPOSITEPROTO_BUILD_DIR) $(J)
- $(Q)$(MAKE) -C $(COMPOSITEPROTO_BUILD_DIR) DESTDIR=$(SYSROOT) install
- $(Q)$(MAKE) libtool_files_adapt
- $(Q)$(MAKE) pkgconfig_files_adapt
- @touch $@
-
-download_compositeproto:
- $(call embtk_generic_message,"Downloading $(COMPOSITEPROTO_PACKAGE) \
- if necessary...")
- @test -e $(DOWNLOAD_DIR)/$(COMPOSITEPROTO_PACKAGE) || \
- wget -O $(DOWNLOAD_DIR)/$(COMPOSITEPROTO_PACKAGE) \
- $(COMPOSITEPROTO_SITE)/$(COMPOSITEPROTO_PACKAGE)
-
-$(COMPOSITEPROTO_BUILD_DIR)/.decompressed:
- $(call embtk_generic_message,"Decompressing $(COMPOSITEPROTO_PACKAGE) ...")
- @tar -C $(PACKAGES_BUILD) -xjvf $(DOWNLOAD_DIR)/$(COMPOSITEPROTO_PACKAGE)
- @touch $@
-
-$(COMPOSITEPROTO_BUILD_DIR)/.configured:
- $(Q)cd $(COMPOSITEPROTO_BUILD_DIR); \
- CC=$(TARGETCC_CACHED) \
- CXX=$(TARGETCXX_CACHED) \
- AR=$(TARGETAR) \
- RANLIB=$(TARGETRANLIB) \
- AS=$(CROSS_COMPILE)as \
- LD=$(TARGETLD) \
- NM=$(TARGETNM) \
- STRIP=$(TARGETSTRIP) \
- OBJDUMP=$(TARGETOBJDUMP) \
- OBJCOPY=$(TARGETOBJCOPY) \
- CFLAGS="$(TARGET_CFLAGS)" \
- CXXFLAGS="$(TARGET_CFLAGS)" \
- LDFLAGS="-L$(SYSROOT)/$(LIBDIR) -L$(SYSROOT)/usr/$(LIBDIR)" \
- CPPFLGAS="-I$(SYSROOT)/usr/include" \
- PKG_CONFIG=$(PKGCONFIG_BIN) \
- PKG_CONFIG_PATH=$(EMBTK_PKG_CONFIG_PATH) \
- ./configure --build=$(HOST_BUILD) --host=$(STRICT_GNU_TARGET) \
- --target=$(STRICT_GNU_TARGET) --libdir=/usr/$(LIBDIR) --prefix=/usr \
- --disable-malloc0returnsnull
- @touch $@
-
-compositeproto_clean:
- $(call embtk_generic_message,"cleanup compositeproto-$(COMPOSITEPROTO_VERSION)...")
- $(Q)-cd $(SYSROOT)/usr/bin; rm -rf $(COMPOSITEPROTO_BINS)
- $(Q)-cd $(SYSROOT)/usr/sbin; rm -rf $(COMPOSITEPROTO_SBINS)
- $(Q)-cd $(SYSROOT)/usr/include; rm -rf $(COMPOSITEPROTO_INCLUDES)
- $(Q)-cd $(SYSROOT)/usr/$(LIBDIR); rm -rf $(COMPOSITEPROTO_LIBS)
- $(Q)-cd $(SYSROOT)/usr/$(LIBDIR)/pkgconfig; rm -rf $(COMPOSITEPROTO_PKGCONFIGS)
- $(Q)-rm -rf $(COMPOSITEPROTO_BUILD_DIR)*
-
+COMPOSITEPROTO_NAME := compositeproto
+COMPOSITEPROTO_VERSION := $(call embtk_get_pkgversion,compositeproto)
+COMPOSITEPROTO_SITE := http://ftp.x.org/pub/individual/proto
+COMPOSITEPROTO_PACKAGE := compositeproto-$(COMPOSITEPROTO_VERSION).tar.bz2
+COMPOSITEPROTO_SRC_DIR := $(PACKAGES_BUILD)/compositeproto-$(COMPOSITEPROTO_VERSION)
+COMPOSITEPROTO_BUILD_DIR := $(PACKAGES_BUILD)/compositeproto-$(COMPOSITEPROTO_VERSION)
+
+COMPOSITEPROTO_BINS =
+COMPOSITEPROTO_SBINS =
+COMPOSITEPROTO_INCLUDES = X11/extensions/compositeproto.h \
+ X11/extensions/composite.h
+COMPOSITEPROTO_LIBS =
+COMPOSITEPROTO_PKGCONFIGS = compositeproto.pc