summaryrefslogtreecommitdiff
path: root/packages/x11/libfontenc/libfontenc.mk
diff options
context:
space:
mode:
Diffstat (limited to 'packages/x11/libfontenc/libfontenc.mk')
-rw-r--r--packages/x11/libfontenc/libfontenc.mk45
1 files changed, 9 insertions, 36 deletions
diff --git a/packages/x11/libfontenc/libfontenc.mk b/packages/x11/libfontenc/libfontenc.mk
index eec6ef3..a728d2a 100644
--- a/packages/x11/libfontenc/libfontenc.mk
+++ b/packages/x11/libfontenc/libfontenc.mk
@@ -23,14 +23,13 @@
# \date March 2010
################################################################################
-LIBFONTENC_NAME := libfontenc
-LIBFONTENC_VERSION := $(call embtk_get_pkgversion,LIBFONTENC)
-LIBFONTENC_SITE := http://xorg.freedesktop.org/archive/individual/lib
-LIBFONTENC_SITE_MIRROR3 := ftp://ftp.embtoolkit.org/embtoolkit.org/packages-mirror
-LIBFONTENC_PATCH_SITE := ftp://ftp.embtoolkit.org/embtoolkit.org/libfontenc/$(LIBFONTENC_VERSION)
-LIBFONTENC_PACKAGE := libfontenc-$(LIBFONTENC_VERSION).tar.bz2
-LIBFONTENC_SRC_DIR := $(PACKAGES_BUILD)/libfontenc-$(LIBFONTENC_VERSION)
-LIBFONTENC_BUILD_DIR := $(PACKAGES_BUILD)/libfontenc-$(LIBFONTENC_VERSION)
+LIBFONTENC_NAME := libfontenc
+LIBFONTENC_VERSION := $(call embtk_get_pkgversion,libfontenc)
+LIBFONTENC_SITE := http://xorg.freedesktop.org/archive/individual/lib
+LIBFONTENC_SITE_MIRROR3 := ftp://ftp.embtoolkit.org/embtoolkit.org/packages-mirror
+LIBFONTENC_PACKAGE := libfontenc-$(LIBFONTENC_VERSION).tar.bz2
+LIBFONTENC_SRC_DIR := $(PACKAGES_BUILD)/libfontenc-$(LIBFONTENC_VERSION)
+LIBFONTENC_BUILD_DIR := $(PACKAGES_BUILD)/libfontenc-$(LIBFONTENC_VERSION)
LIBFONTENC_BINS =
LIBFONTENC_SBINS =
@@ -38,32 +37,6 @@ LIBFONTENC_INCLUDES = X11/fonts/fontenc.h
LIBFONTENC_LIBS = libfontenc.*
LIBFONTENC_PKGCONFIGS = libfontenc.pc
-LIBFONTENC_CONFIGURE_OPTS := --disable-malloc0returnsnull
+LIBFONTENC_CONFIGURE_OPTS := --disable-malloc0returnsnull
+LIBFONTENC_DEPS := zlib_install
-LIBFONTENC_DEPS := zlib_install
-
-libfontenc_install:
- @test -e $(LIBFONTENC_BUILD_DIR)/.installed || \
- $(MAKE) $(LIBFONTENC_BUILD_DIR)/.installed
-
-$(LIBFONTENC_BUILD_DIR)/.installed: $(LIBFONTENC_DEPS) download_libfontenc \
- $(LIBFONTENC_BUILD_DIR)/.decompressed $(LIBFONTENC_BUILD_DIR)/.configured
- $(call embtk_generic_message,"Compiling and installing \
- libfontenc-$(LIBFONTENC_VERSION) in your root filesystem...")
- $(Q)$(MAKE) -C $(LIBFONTENC_BUILD_DIR) $(J)
- $(Q)$(MAKE) -C $(LIBFONTENC_BUILD_DIR) DESTDIR=$(SYSROOT) install
- $(Q)$(MAKE) libtool_files_adapt
- $(Q)$(MAKE) pkgconfig_files_adapt
- @touch $@
-
-download_libfontenc:
- $(call embtk_download_pkg,LIBFONTENC)
-
-$(LIBFONTENC_BUILD_DIR)/.decompressed:
- $(call embtk_decompress_pkg,LIBFONTENC)
-
-$(LIBFONTENC_BUILD_DIR)/.configured:
- $(call embtk_configure_pkg,LIBFONTENC)
-
-libfontenc_clean:
- $(call embtk_cleanup_pkg,LIBFONTENC)