summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorzhanyong.wan <zhanyong.wan@861a406c-534a-0410-8894-cb66d6ee9925>2010-03-26 05:35:42 +0000
committerzhanyong.wan <zhanyong.wan@861a406c-534a-0410-8894-cb66d6ee9925>2010-03-26 05:35:42 +0000
commit14673f3c3db0f629284b8462168891b16a7524dc (patch)
treef9fcb5772dd668f165b69e502f9ca9886c920e27 /CMakeLists.txt
parentce53a0006ba1b71302b469dff21c4e528ca5505d (diff)
downloadgtest-14673f3c3db0f629284b8462168891b16a7524dc.tar.gz
gtest-14673f3c3db0f629284b8462168891b16a7524dc.tar.bz2
gtest-14673f3c3db0f629284b8462168891b16a7524dc.tar.xz
Fixes compatibility with Visual Age versions lower than 9.0 (by Hady Zalek); updates the release notes.
git-svn-id: http://googletest.googlecode.com/svn/trunk@407 861a406c-534a-0410-8894-cb66d6ee9925
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e8d18bd..4c80bde 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -88,7 +88,10 @@ elseif ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "SunPro")
elseif ("${CMAKE_CXX_COMPILER_ID}" STREQUAL "VisualAge")
set(cxx_exception_flags "-qeh")
set(cxx_no_exception_flags "-qnoeh")
- set(cxx_no_rtti_flags "-qnortti")
+ # Until version 9.0, Visual Age doesn't define a macro to indicate
+ # whether RTTI is enabled. Therefore we define GTEST_HAS_RTTI
+ # explicitly.
+ set(cxx_no_rtti_flags "-qnortti -DGTEST_HAS_RTTI=0")
endif()
if (CMAKE_USE_PTHREADS_INIT) # The pthreads library is available.