summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorchandlerc <chandlerc@861a406c-534a-0410-8894-cb66d6ee9925>2009-08-11 02:16:16 +0000
committerchandlerc <chandlerc@861a406c-534a-0410-8894-cb66d6ee9925>2009-08-11 02:16:16 +0000
commit31e3f1e48f17b7ec30371ded8ae1b6ac1b63c8b3 (patch)
tree8abb790062a2bd3c176818c0a094701348c6baa2 /Makefile.am
parent7615fa0aeda6536312c5661979345f696f324ff0 (diff)
downloadgtest-31e3f1e48f17b7ec30371ded8ae1b6ac1b63c8b3.tar.gz
gtest-31e3f1e48f17b7ec30371ded8ae1b6ac1b63c8b3.tar.bz2
gtest-31e3f1e48f17b7ec30371ded8ae1b6ac1b63c8b3.tar.xz
Fix the 'make dist' behavior to include gtest-tuple.h and gtest-tuple.h.pump.
Missing these caused failures on platforms depending on them as well as general failures of the dedicated tests for the tuple implementation. Change was tested by running 'make distcheck' and then extracting the result to an entirely separate location (a subdirectory is insufficient, thank you Autotools) and running './configure; make check'. git-svn-id: http://googletest.googlecode.com/svn/trunk@292 861a406c-534a-0410-8894-cb66d6ee9925
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am2
1 files changed, 2 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index e56fadf..2f7e911 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -7,6 +7,7 @@ EXTRA_DIST = \
CHANGES \
CONTRIBUTORS \
include/gtest/gtest-param-test.h.pump \
+ include/gtest/internal/gtest-tuple.h.pump \
include/gtest/internal/gtest-type-util.h.pump \
include/gtest/internal/gtest-param-util-generated.h.pump \
make/Makefile \
@@ -109,6 +110,7 @@ pkginclude_internal_HEADERS = \
include/gtest/internal/gtest-param-util.h \
include/gtest/internal/gtest-port.h \
include/gtest/internal/gtest-string.h \
+ include/gtest/internal/gtest-tuple.h \
include/gtest/internal/gtest-type-util.h
lib_libgtest_main_la_SOURCES = src/gtest_main.cc