summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorshiqian <shiqian@861a406c-534a-0410-8894-cb66d6ee9925>2008-07-09 20:58:26 +0000
committershiqian <shiqian@861a406c-534a-0410-8894-cb66d6ee9925>2008-07-09 20:58:26 +0000
commit4f1d72ed86ade239a3a03b4cb4482012daab0bff (patch)
tree81afa87cb21e28946ccd96f22fce35c4158c6d51 /Makefile.am
parent752c403d4b79a60bed6f153c8408020be9f3cb6e (diff)
downloadgtest-4f1d72ed86ade239a3a03b4cb4482012daab0bff.tar.gz
gtest-4f1d72ed86ade239a3a03b4cb4482012daab0bff.tar.bz2
gtest-4f1d72ed86ade239a3a03b4cb4482012daab0bff.tar.xz
Makes Google Test compile on Mac OS X and Cygwin, and adds project files for Microsoft Visual Studio.
git-svn-id: http://googletest.googlecode.com/svn/trunk@55 861a406c-534a-0410-8894-cb66d6ee9925
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am13
1 files changed, 13 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 76daa30..c6e8707 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -6,6 +6,19 @@ EXTRA_DIST = \
CONTRIBUTORS \
scripts/gen_gtest_pred_impl.py
+# MSVC project files
+EXTRA_DIST += \
+ msvc/gtest.sln \
+ msvc/gtest.vcproj \
+ msvc/gtest_color_test_.vcproj \
+ msvc/gtest_env_var_test_.vcproj \
+ msvc/gtest_environment_test.vcproj \
+ msvc/gtest_main.vcproj \
+ msvc/gtest_output_test_.vcproj \
+ msvc/gtest_prod_test.vcproj \
+ msvc/gtest_uninitialized_test_.vcproj \
+ msvc/gtest_unittest.vcproj
+
# TODO(wan@google.com): integrate scripts/gen_gtest_pred_impl.py into
# the build system such that a user can specify the maximum predicate
# arity here and have the script automatically generate the