summaryrefslogtreecommitdiff
path: root/Makefile.am
diff options
context:
space:
mode:
authorzhanyong.wan <zhanyong.wan@861a406c-534a-0410-8894-cb66d6ee9925>2009-06-17 21:06:27 +0000
committerzhanyong.wan <zhanyong.wan@861a406c-534a-0410-8894-cb66d6ee9925>2009-06-17 21:06:27 +0000
commit6d63ee6720540cadb8919037c5d41a6413cc9101 (patch)
tree1dd721d45ddd731134dda23f8368781979dc0b09 /Makefile.am
parent16b967aa9c80cf8606c65d375865b77a6bcad255 (diff)
downloadgtest-6d63ee6720540cadb8919037c5d41a6413cc9101.tar.gz
gtest-6d63ee6720540cadb8919037c5d41a6413cc9101.tar.bz2
gtest-6d63ee6720540cadb8919037c5d41a6413cc9101.tar.xz
Implements a subset of TR1 tuple needed by gtest and gmock (by Zhanyong Wan); cleaned up the Python tests (by Vlad Losev); made run_tests.py invokable from any directory (by Vlad Losev).
git-svn-id: http://googletest.googlecode.com/svn/trunk@267 861a406c-534a-0410-8894-cb66d6ee9925
Diffstat (limited to 'Makefile.am')
-rw-r--r--Makefile.am17
1 files changed, 17 insertions, 0 deletions
diff --git a/Makefile.am b/Makefile.am
index 148a076..eba2776 100644
--- a/Makefile.am
+++ b/Makefile.am
@@ -300,6 +300,23 @@ test_gtest_no_rtti_test_SOURCES = test/gtest_unittest.cc \
src/gtest_main.cc
test_gtest_no_rtti_test_CXXFLAGS = $(AM_CXXFLAGS) -fno-rtti -DGTEST_HAS_RTTI=0
+# Verifies that Google Test's own TR1 tuple implementation works.
+TESTS += test/gtest-tuple_test
+check_PROGRAMS += test/gtest-tuple_test
+test_gtest_tuple_test_SOURCES = test/gtest-tuple_test.cc \
+ src/gtest-all.cc \
+ src/gtest_main.cc
+test_gtest_tuple_test_CXXFLAGS = $(AM_CXXFLAGS) -DGTEST_USE_OWN_TR1_TUPLE=1
+
+# Verifies that Google Test's features that use its own TR1 tuple work.
+TESTS += test/gtest_use_own_tuple_test
+check_PROGRAMS += test/gtest_use_own_tuple_test
+test_gtest_use_own_tuple_test_SOURCES = test/gtest-param-test_test.cc \
+ test/gtest-param-test2_test.cc \
+ src/gtest-all.cc
+test_gtest_use_own_tuple_test_CXXFLAGS = \
+ $(AM_CXXFLAGS) -DGTEST_USE_OWN_TR1_TUPLE=1
+
# The following tests depend on the presence of a Python installation and are
# keyed off of it. TODO(chandlerc@google.com): While we currently only attempt
# to build and execute these tests if Autoconf has found Python v2.4 on the