summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authoranonymous <local@localhost>2010-07-02 19:12:29 +0700
committeranonymous <local@localhost>2010-07-02 22:14:18 +0700
commit3310d8a2909b5759686452e68159cbca61038a40 (patch)
treec6c40d81352f6e251b67cd25a36c8e74592decae /CMakeLists.txt
parent2c08f2cdacd5f35cadc9b41a8aee9a28d14da939 (diff)
downloadlibcxxrt-3310d8a2909b5759686452e68159cbca61038a40.tar.gz
libcxxrt-3310d8a2909b5759686452e68159cbca61038a40.tar.bz2
libcxxrt-3310d8a2909b5759686452e68159cbca61038a40.tar.xz
cmake scripts for testing are added
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index abd531c..403d43f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -1,5 +1,11 @@
cmake_minimum_required(VERSION 2.8.1)
+enable_testing()
+
+set(CMAKE_RUNTIME_OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/bin")
+set(CMAKE_LIBRARY_OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/lib")
+set(CMAKE_ARCHIVE_OUTPUT_DIRECTORY "${CMAKE_CURRENT_BINARY_DIR}/lib")
+
add_subdirectory(src)
add_subdirectory(test)