summaryrefslogtreecommitdiff
path: root/test/CMakeLists.txt
diff options
context:
space:
mode:
authoranonymous <local@localhost>2010-07-29 01:00:54 +0700
committeranonymous <local@localhost>2010-08-31 18:05:39 +0700
commit50989850d21bece7e421dfbbc5ef165e0e66bb50 (patch)
tree7df15aa2014cce6af6c6e3010e7b55ea74adbf01 /test/CMakeLists.txt
parentac2ce15ad1b4907a346179a35f4fca2e6960c800 (diff)
downloadlibcxxrt-50989850d21bece7e421dfbbc5ef165e0e66bb50.tar.gz
libcxxrt-50989850d21bece7e421dfbbc5ef165e0e66bb50.tar.bz2
libcxxrt-50989850d21bece7e421dfbbc5ef165e0e66bb50.tar.xz
Fixes in tests
Diffstat (limited to 'test/CMakeLists.txt')
-rw-r--r--test/CMakeLists.txt13
1 files changed, 6 insertions, 7 deletions
diff --git a/test/CMakeLists.txt b/test/CMakeLists.txt
index 6e6ea58..99ad4d1 100644
--- a/test/CMakeLists.txt
+++ b/test/CMakeLists.txt
@@ -15,21 +15,20 @@ target_link_libraries(cxxrt-test-shared cxxrt-shared pthread dl)
add_executable(system-test ${CXXTEST_SOURCES})
-file(READ "${CMAKE_CURRENT_SOURCE_DIR}/expected_output.log" expected_output)
+# Generating excpected output with system-test
+add_custom_target(test-expected-output ALL
+ COMMAND system-test > ${CMAKE_CURRENT_BINARY_DIR}/expected_output.log 2>&1
+ DEPENDS system-test)
-add_test(system-test-test
- ${CMAKE_CURRENT_SOURCE_DIR}/run_test.sh
- ${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/system-test
- ${CMAKE_CURRENT_SOURCE_DIR}/expected_output.log)
add_test(cxxrt-test-static-test
${CMAKE_CURRENT_SOURCE_DIR}/run_test.sh
${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/cxxrt-test-static
- ${CMAKE_CURRENT_SOURCE_DIR}/expected_output.log)
+ ${CMAKE_CURRENT_BINARY_DIR}/expected_output.log)
add_test(cxxrt-test-shared-test
${CMAKE_CURRENT_SOURCE_DIR}/run_test.sh
${CMAKE_RUNTIME_OUTPUT_DIRECTORY}/cxxrt-test-shared
- ${CMAKE_CURRENT_SOURCE_DIR}/expected_output.log)
+ ${CMAKE_CURRENT_BINARY_DIR}/expected_output.log)