summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2010-09-25 20:25:25 +0000
committerOscar Fuentes <ofv@wanadoo.es>2010-09-25 20:25:25 +0000
commit066de857f813991cb8985c7b10e130b32c878bd6 (patch)
tree92207a1868247905d941699eabf4159ba6f6a552 /CMakeLists.txt
parent207f8f688b0d530ebe4542ae0db599a6463b670b (diff)
downloadllvm-066de857f813991cb8985c7b10e130b32c878bd6.tar.gz
llvm-066de857f813991cb8985c7b10e130b32c878bd6.tar.bz2
llvm-066de857f813991cb8985c7b10e130b32c878bd6.tar.xz
Reverting "CMake: Don't include tools, unittets, or examples as
available targets unless LLVM_INCLUDE_X is ON. LLVM_BUILD_X implies LLVM_INCLUDE_X" It breaks the configuration phase when cmake is invoked without parameters, it is too complex for the purpose and introduces an incovenience for the user (as both LLVM_BUILD_X and LLVM_INCLUDE_X must set to OFF for not including X on the build) git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@114795 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8b2b2dc36a..7959f65647 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -364,18 +364,12 @@ add_subdirectory(lib/Archive)
add_subdirectory(projects)
option(LLVM_BUILD_TOOLS "Build LLVM tool programs." ON)
-option(LLVM_INCLUDE_TOOLS
- "Include LLVM tool programs as an available target." ON)
add_subdirectory(tools)
option(LLVM_BUILD_EXAMPLES "Build LLVM example programs." OFF)
-option(LLVM_INCLUDE_EXAMPLES
- "Include LLVM example programs as an available target." OFF)
add_subdirectory(examples)
option(LLVM_BUILD_TESTS "Build LLVM unit tests." OFF)
-option(LLVM_INCLUDE_TESTS
- "Include LLVM unit tests as an available target." OFF)
add_subdirectory(test)
add_subdirectory(utils/unittest)
add_subdirectory(unittests)