summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorJim Grosbach <grosbach@apple.com>2010-10-02 00:39:56 +0000
committerJim Grosbach <grosbach@apple.com>2010-10-02 00:39:56 +0000
commit0e69aff03aa796563f7b21e9dbb17344efa017c4 (patch)
tree4e2f07e116c96ab564f0ef687ddf2a83a33d3602 /CMakeLists.txt
parent890dbbec5773fb4d3823e3102d403d79900b08bc (diff)
downloadllvm-0e69aff03aa796563f7b21e9dbb17344efa017c4.tar.gz
llvm-0e69aff03aa796563f7b21e9dbb17344efa017c4.tar.bz2
llvm-0e69aff03aa796563f7b21e9dbb17344efa017c4.tar.xz
Update CMake files for recent AsmPrinter->InstPrinter changes. Can someone who
is more familiar with CMake please review? git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@115391 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 4 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 8ad68a0457..7f3ec802df 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -323,6 +323,10 @@ foreach(t ${LLVM_TARGETS_TO_BUILD})
add_subdirectory(lib/Target/${t}/AsmPrinter)
set(LLVM_ENUM_ASM_PRINTERS
"${LLVM_ENUM_ASM_PRINTERS}LLVM_ASM_PRINTER(${t})\n")
+ if( EXISTS ${LLVM_MAIN_SRC_DIR}/lib/Target/${t}/InstPrinter/CMakeLists.txt )
+ add_subdirectory(lib/Target/${t}/InstPrinter)
+ set(LLVM_ENUM_ASM_PRINTERS
+ "${LLVM_ENUM_ASM_PRINTERS}LLVM_ASM_PRINTER(${t})\n")
endif( EXISTS ${LLVM_MAIN_SRC_DIR}/lib/Target/${t}/AsmPrinter/CMakeLists.txt )
if( EXISTS ${LLVM_MAIN_SRC_DIR}/lib/Target/${t}/AsmParser/CMakeLists.txt )
add_subdirectory(lib/Target/${t}/AsmParser)