summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Lattner <sabre@nondot.org>2010-11-14 18:43:56 +0000
committerChris Lattner <sabre@nondot.org>2010-11-14 18:43:56 +0000
commit1139691e3aadff751c035f38f835d436ec6cf10a (patch)
tree8287424f01072c252a61fe2a95498f545bf21b3e /CMakeLists.txt
parenteff0581583ef10e2872e9baf537a04b67d992101 (diff)
downloadllvm-1139691e3aadff751c035f38f835d436ec6cf10a.tar.gz
llvm-1139691e3aadff751c035f38f835d436ec6cf10a.tar.bz2
llvm-1139691e3aadff751c035f38f835d436ec6cf10a.tar.xz
move all the target's asmprinters into the main target. The piece
that should be split out is the InstPrinter (if a target is mc'ized). This change makes all the targets be consistent. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@119056 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 0 insertions, 5 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index a028edf774..d549e83593 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -328,11 +328,6 @@ foreach(t ${LLVM_TARGETS_TO_BUILD})
message(STATUS "Targeting ${t}")
add_subdirectory(lib/Target/${t})
add_subdirectory(lib/Target/${t}/TargetInfo)
- if( EXISTS ${LLVM_MAIN_SRC_DIR}/lib/Target/${t}/AsmPrinter/CMakeLists.txt )
- add_subdirectory(lib/Target/${t}/AsmPrinter)
- set(LLVM_ENUM_ASM_PRINTERS
- "${LLVM_ENUM_ASM_PRINTERS}LLVM_ASM_PRINTER(${t})\n")
- endif( EXISTS ${LLVM_MAIN_SRC_DIR}/lib/Target/${t}/AsmPrinter/CMakeLists.txt )
if( EXISTS ${LLVM_MAIN_SRC_DIR}/lib/Target/${t}/InstPrinter/CMakeLists.txt )
add_subdirectory(lib/Target/${t}/InstPrinter)
set(LLVM_ENUM_ASM_PRINTERS