summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorFrancois Pichet <pichet2000@gmail.com>2011-01-17 02:07:17 +0000
committerFrancois Pichet <pichet2000@gmail.com>2011-01-17 02:07:17 +0000
commit119266c4ae2803e11229034b74813242b5978566 (patch)
tree900babe244d57d69451ee1b0e6cb359888c4aaaa /CMakeLists.txt
parentebed6de7b10d20721f5bd30ed3730cadefed7963 (diff)
downloadllvm-119266c4ae2803e11229034b74813242b5978566.tar.gz
llvm-119266c4ae2803e11229034b74813242b5978566.tar.bz2
llvm-119266c4ae2803e11229034b74813242b5978566.tar.xz
Suppress warning "switch statement contains 'default' but no 'case' labels" on MSVC.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@123610 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 1 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7df188560b..52f0a5815b 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -286,6 +286,7 @@ if( MSVC )
-wd4624 # Suppress ''derived class' : destructor could not be generated because a base class destructor is inaccessible'
-wd4715 # Suppress ''function' : not all control paths return a value'
-wd4800 # Suppress ''type' : forcing value to bool 'true' or 'false' (performance warning)'
+ -wd4065 # Suppress 'switch statement contains 'default' but no 'case' labels'
-w14062 # Promote "enumerator in switch of enum is not handled" to level 1 warning.
)