summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2009-10-27 19:57:29 +0000
committerOscar Fuentes <ofv@wanadoo.es>2009-10-27 19:57:29 +0000
commit1d7c43b7e730346540cf843e2618fe1342d93405 (patch)
treeeff111dc3e69883ca8139373747a19bdd85ccd49 /CMakeLists.txt
parenteb2f969a4ddfb0bc8fdcb5bce3b52e53abff321d (diff)
downloadllvm-1d7c43b7e730346540cf843e2618fe1342d93405.tar.gz
llvm-1d7c43b7e730346540cf843e2618fe1342d93405.tar.bz2
llvm-1d7c43b7e730346540cf843e2618fe1342d93405.tar.xz
Rather than excluding quite some things, and still installing
CMakeLists.txt, Makefiles, ... it's better to whitelist what we really want to install. Patch by Ingmar Vanhassel! git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@85282 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 14 insertions, 7 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index f7126584ba..40a81d7b32 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -319,16 +319,23 @@ if(LLVM_BUILD_EXAMPLES)
add_subdirectory(examples)
endif ()
-install(DIRECTORY include
- DESTINATION .
+install(DIRECTORY include/
+ DESTINATION include
+ FILES_MATCHING
+ PATTERN "*.h"
+ PATTERN "*.td"
PATTERN ".svn" EXCLUDE
- PATTERN "*.cmake" EXCLUDE
- PATTERN "*.in" EXCLUDE
- PATTERN "*.tmp" EXCLUDE
)
-install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/include
- DESTINATION .
+install(DIRECTORY ${CMAKE_CURRENT_BINARY_DIR}/include/
+ DESTINATION include
+ FILES_MATCHING
+ PATTERN "*.def"
+ PATTERN "*.h"
+ PATTERN "*.gen"
+ # Exclude include/llvm/CMakeFiles/intrinsics_gen.dir, matched by "*.def"
+ PATTERN "CMakeFiles" EXCLUDE
+ PATTERN ".svn" EXCLUDE
)
# TODO: make and install documentation.