summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNAKAMURA Takumi <geek4civic@gmail.com>2014-02-10 10:50:55 +0000
committerNAKAMURA Takumi <geek4civic@gmail.com>2014-02-10 10:50:55 +0000
commit282713c09b592e0d49d3c34e6b3bf62462a17933 (patch)
tree107cd871320914b6d5d367547776950c998d761e /CMakeLists.txt
parent0eefad30d46364aeec0c5264153a02856d76e2c1 (diff)
downloadllvm-282713c09b592e0d49d3c34e6b3bf62462a17933.tar.gz
llvm-282713c09b592e0d49d3c34e6b3bf62462a17933.tar.bz2
llvm-282713c09b592e0d49d3c34e6b3bf62462a17933.tar.xz
Fix LLVM install rules to not set permissions on include/
The CMake install(DIRECTORY) command documents that it sets permissions on directories it is asked to install. Since the <prefix>/include directory may not be exclusive to the LLVM installation, we should not ask CMake to manage permissions of that directory for us. Instead, give only our own include/llvm and include/llvm-c subdirectories to the install(DIRECTORY) command. Fixes PR4500. Patch by Brad King. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@201075 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 2 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 122c47d4a8..cd8b363f7a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -517,7 +517,7 @@ endif()
add_subdirectory(cmake/modules)
if (NOT LLVM_INSTALL_TOOLCHAIN_ONLY)
- install(DIRECTORY include/
+ install(DIRECTORY include/llvm include/llvm-c
DESTINATION include
FILES_MATCHING
PATTERN "*.def"
@@ -528,7 +528,7 @@ if (NOT LLVM_INSTALL_TOOLCHAIN_ONLY)
PATTERN ".svn" EXCLUDE
)
- install(DIRECTORY ${LLVM_INCLUDE_DIR}/
+ install(DIRECTORY ${LLVM_INCLUDE_DIR}/llvm
DESTINATION include
FILES_MATCHING
PATTERN "*.def"