summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDaniel Dunbar <daniel@zuster.org>2009-07-19 01:35:10 +0000
committerDaniel Dunbar <daniel@zuster.org>2009-07-19 01:35:10 +0000
commit2c4df5a95d980260fa67c9360a4f24f397727d29 (patch)
tree2799c0151b057b9cf0a536dc96a5171c7ce47d29 /CMakeLists.txt
parentc6465511d1b60a9becbe1dc442007ce977df5e3d (diff)
downloadllvm-2c4df5a95d980260fa67c9360a4f24f397727d29.tar.gz
llvm-2c4df5a95d980260fa67c9360a4f24f397727d29.tar.bz2
llvm-2c4df5a95d980260fa67c9360a4f24f397727d29.tar.xz
MSVC: Disable 4351, a completely useless warning: "warning: I'm not miscompiling
this". Um, ok, thanks! git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@76355 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index bacb07a33e..90382503e4 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -205,6 +205,9 @@ if( MSVC )
add_llvm_definitions( -wd4146 -wd4503 -wd4996 -wd4800 -wd4244 -wd4624 )
add_llvm_definitions( -wd4355 -wd4715 -wd4180 -wd4345 -wd4224 )
+ # Suppress 'new behavior: elements of array 'array' will be default initialized'
+ add_llvm_definitions( -wd4351 )
+
if (NOT ${LLVM_USE_CRT} STREQUAL "")
list(FIND MSVC_CRT ${LLVM_USE_CRT} idx)
if (idx LESS 0)