summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorRafael Espindola <rafael.espindola@gmail.com>2014-02-28 13:48:03 +0000
committerRafael Espindola <rafael.espindola@gmail.com>2014-02-28 13:48:03 +0000
commit37c04a0d4d0df0e2efddcc76a1036a9fc384e61a (patch)
tree40f9e660892b4c7ec1b5f6a4c8b1c92750e4313a /CMakeLists.txt
parent2dc637fce3aebbea030ddce74e223f23c4aa3513 (diff)
downloadllvm-37c04a0d4d0df0e2efddcc76a1036a9fc384e61a.tar.gz
llvm-37c04a0d4d0df0e2efddcc76a1036a9fc384e61a.tar.bz2
llvm-37c04a0d4d0df0e2efddcc76a1036a9fc384e61a.tar.xz
Centralize the handling of install_name and rpath.
This centralizes the Makefile handling of -install_name and -rpath. It also moves the cmake build to using @rpath. The reason being that libclang needs it, and it works for everything else. A followup patch will move clang to using this and then there will be a single point to edit to support other systems. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@202499 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 72901c8876..ab93503f28 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -443,7 +443,7 @@ set( CMAKE_ARCHIVE_OUTPUT_DIRECTORY ${LLVM_BINARY_DIR}/lib )
set(CMAKE_BUILD_WITH_INSTALL_RPATH ON)
if (APPLE)
- set(CMAKE_INSTALL_NAME_DIR "@executable_path/../lib")
+ set(CMAKE_INSTALL_NAME_DIR "@rpath")
set(CMAKE_INSTALL_RPATH "@executable_path/../lib")
else(UNIX)
if(NOT DEFINED CMAKE_INSTALL_RPATH)