summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2009-08-14 05:17:24 +0000
committerOscar Fuentes <ofv@wanadoo.es>2009-08-14 05:17:24 +0000
commit3d3ed3657268ab814a7f9ca952b32148d493c0be (patch)
treeb60728f6d638be7b5d857f571025f933dee1b763 /CMakeLists.txt
parent22cac0d9b328ef89a6aafdbda9cd0cea71f8ce46 (diff)
downloadllvm-3d3ed3657268ab814a7f9ca952b32148d493c0be.tar.gz
llvm-3d3ed3657268ab814a7f9ca952b32148d493c0be.tar.bz2
llvm-3d3ed3657268ab814a7f9ca952b32148d493c0be.tar.xz
CMake: Builds main LLVM Target library before its sublibraries. This
way we ensure that tablegenned files exist before they are #include'd by the LLVM Target sublibraries. Required for parallel builds. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@78996 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 2 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 068ef963af..32dcae79f6 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -266,6 +266,7 @@ set(LLVM_ENUM_ASM_PRINTERS "")
set(LLVM_ENUM_ASM_PARSERS "")
foreach(t ${LLVM_TARGETS_TO_BUILD})
message(STATUS "Targeting ${t}")
+ set(CURRENT_LLVM_TARGET ${t})
add_subdirectory(lib/Target/${t})
add_subdirectory(lib/Target/${t}/TargetInfo)
if( EXISTS ${LLVM_MAIN_SRC_DIR}/lib/Target/${t}/AsmPrinter/CMakeLists.txt )
@@ -278,6 +279,7 @@ foreach(t ${LLVM_TARGETS_TO_BUILD})
set(LLVM_ENUM_ASM_PARSERS
"${LLVM_ENUM_ASM_PARSERS}LLVM_ASM_PARSER(${t})\n")
endif( EXISTS ${LLVM_MAIN_SRC_DIR}/lib/Target/${t}/AsmParser/CMakeLists.txt )
+ set(CURRENT_LLVM_TARGET)
endforeach(t)
# Produce llvm/Config/AsmPrinters.def