summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2010-03-18 13:52:05 +0000
committerOscar Fuentes <ofv@wanadoo.es>2010-03-18 13:52:05 +0000
commit3f0cc8c268ef17536690907dbdf3ef488e8fe994 (patch)
treefa7d061e8d9c002f25804bfd7586dea587c2c955 /CMakeLists.txt
parente7e891f6af02685b6706baa3632f3219789c711a (diff)
downloadllvm-3f0cc8c268ef17536690907dbdf3ef488e8fe994.tar.gz
llvm-3f0cc8c268ef17536690907dbdf3ef488e8fe994.tar.bz2
llvm-3f0cc8c268ef17536690907dbdf3ef488e8fe994.tar.xz
CMake: Add options for using static runtime on MSVC++ build.
Patch by Victor Zverovich! git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@98821 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt4
1 files changed, 3 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 96e06082fd..9d0180b86f 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -217,7 +217,9 @@ if( MSVC )
# List of valid CRTs for MSVC
set(MSVC_CRT
MD
- MDd)
+ MDd
+ MT
+ MTd)
set(LLVM_USE_CRT "" CACHE STRING "Specify VC++ CRT to use for debug/release configurations.")
add_llvm_definitions( -D_CRT_SECURE_NO_DEPRECATE -D_CRT_SECURE_NO_WARNINGS )