summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael J. Spencer <bigcheesegs@gmail.com>2010-09-24 19:10:51 +0000
committerMichael J. Spencer <bigcheesegs@gmail.com>2010-09-24 19:10:51 +0000
commit4b794c9a9990fdea831966c7ebd3be46efe261a1 (patch)
tree2917a166e0c6a1c1d7b8e5cb03d15cfb9b70f746 /CMakeLists.txt
parentfff606d7b2d65495050360056acc65ec667a93b5 (diff)
downloadllvm-4b794c9a9990fdea831966c7ebd3be46efe261a1.tar.gz
llvm-4b794c9a9990fdea831966c7ebd3be46efe261a1.tar.bz2
llvm-4b794c9a9990fdea831966c7ebd3be46efe261a1.tar.xz
CMake: Don't include tools, unittets, or examples as available targets
unless LLVM_INCLUDE_X is ON. LLVM_BUILD_X implies LLVM_INCLUDE_X git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@114747 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 6 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 7959f65647..8b2b2dc36a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -364,12 +364,18 @@ add_subdirectory(lib/Archive)
add_subdirectory(projects)
option(LLVM_BUILD_TOOLS "Build LLVM tool programs." ON)
+option(LLVM_INCLUDE_TOOLS
+ "Include LLVM tool programs as an available target." ON)
add_subdirectory(tools)
option(LLVM_BUILD_EXAMPLES "Build LLVM example programs." OFF)
+option(LLVM_INCLUDE_EXAMPLES
+ "Include LLVM example programs as an available target." OFF)
add_subdirectory(examples)
option(LLVM_BUILD_TESTS "Build LLVM unit tests." OFF)
+option(LLVM_INCLUDE_TESTS
+ "Include LLVM unit tests as an available target." OFF)
add_subdirectory(test)
add_subdirectory(utils/unittest)
add_subdirectory(unittests)