summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorNAKAMURA Takumi <geek4civic@gmail.com>2010-11-19 03:19:18 +0000
committerNAKAMURA Takumi <geek4civic@gmail.com>2010-11-19 03:19:18 +0000
commit4c8710d9171da1e46ee6e209c9ffc44944869a20 (patch)
tree569a5d0caa86381cad071a2a1a797af15f8ee0eb /CMakeLists.txt
parent195a0ce484cd12a5adae9184188f6d0fb52b84c0 (diff)
downloadllvm-4c8710d9171da1e46ee6e209c9ffc44944869a20.tar.gz
llvm-4c8710d9171da1e46ee6e209c9ffc44944869a20.tar.bz2
llvm-4c8710d9171da1e46ee6e209c9ffc44944869a20.tar.xz
CMakeLists.txt: On MSVS10, touch LLVM.sln as workaround, w/e project files are changed, to avoid the Dialog Hell. Thanks to Oscar.
FIXME: This could be removed with future version of CMake. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@119780 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt9
1 files changed, 9 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 078c961df4..62a08b250a 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -438,3 +438,12 @@ set(CPACK_PACKAGE_VERSION_MAJOR 2)
set(CPACK_PACKAGE_VERSION_MINOR 9)
add_version_info_from_vcs(CPACK_PACKAGE_VERSION_PATCH)
include(CPack)
+
+# Workaround for MSVS10 to avoid the Dialog Hell
+# FIXME: This could be removed with future version of CMake.
+if(MSVC_VERSION EQUAL 1600)
+ set(LLVM_SLN_FILENAME "${CMAKE_CURRENT_BINARY_DIR}/LLVM.sln")
+ if( EXISTS "${LLVM_SLN_FILENAME}" )
+ file(APPEND "${LLVM_SLN_FILENAME}" "\n# This should be regenerated!\n")
+ endif()
+endif()