summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2010-09-28 14:02:45 +0000
committerOscar Fuentes <ofv@wanadoo.es>2010-09-28 14:02:45 +0000
commit4dbb2dbf764498e6f03de0459b9c40fba5e608be (patch)
tree1fb6f4156fbdeab9dd77bbece2812fb628068267 /CMakeLists.txt
parentb2c70cfc71f401ae7eae26b29ea081bf7e7b917f (diff)
downloadllvm-4dbb2dbf764498e6f03de0459b9c40fba5e608be.tar.gz
llvm-4dbb2dbf764498e6f03de0459b9c40fba5e608be.tar.bz2
llvm-4dbb2dbf764498e6f03de0459b9c40fba5e608be.tar.xz
Added library LLVMPIC16passes to CMake build.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@114952 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 5 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 164ed3a3f4..8ad68a0457 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -337,6 +337,11 @@ foreach(t ${LLVM_TARGETS_TO_BUILD})
set(CURRENT_LLVM_TARGET)
endforeach(t)
+# PIC16 contains an odd library:
+if( LLVM_TARGETS_TO_BUILD MATCHES ".*PIC16.*" )
+ add_subdirectory(lib/Target/PIC16/PIC16Passes)
+endif()
+
# Produce llvm/Config/AsmPrinters.def
configure_file(
${LLVM_MAIN_INCLUDE_DIR}/llvm/Config/AsmPrinters.def.in