summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorMichael J. Spencer <bigcheesegs@gmail.com>2010-12-18 00:18:58 +0000
committerMichael J. Spencer <bigcheesegs@gmail.com>2010-12-18 00:18:58 +0000
commit57e9104318a6b3b37f4c590b9229991600e1b0dc (patch)
tree3e25e66978d38f439f1448b6df542a249008e0e4 /CMakeLists.txt
parenta479b2325635544fb2c955c4d7e8b6ea9582120f (diff)
downloadllvm-57e9104318a6b3b37f4c590b9229991600e1b0dc.tar.gz
llvm-57e9104318a6b3b37f4c590b9229991600e1b0dc.tar.bz2
llvm-57e9104318a6b3b37f4c590b9229991600e1b0dc.tar.xz
CMake: Cleanup and document MSVC warning flags.
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@122115 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt39
1 files changed, 27 insertions, 12 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index aec7d65689..df2f8d5d51 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -242,18 +242,33 @@ endif( CMAKE_SIZEOF_VOID_P EQUAL 8 AND NOT WIN32 )
if( MSVC )
include(ChooseMSVCCRT)
- add_llvm_definitions( -D_CRT_SECURE_NO_DEPRECATE -D_CRT_SECURE_NO_WARNINGS )
- add_llvm_definitions( -D_SCL_SECURE_NO_WARNINGS -DCRT_NONSTDC_NO_WARNINGS )
- add_llvm_definitions( -D_SCL_SECURE_NO_DEPRECATE )
- add_llvm_definitions( -wd4146 -wd4503 -wd4996 -wd4800 -wd4244 -wd4624 )
- add_llvm_definitions( -wd4355 -wd4715 -wd4180 -wd4345 -wd4224 -wd4267 -wd4291 )
- add_llvm_definitions( -wd4275 )
-
- # Promote "enumerator in switch of enum is not handled" to level 1 warning.
- add_llvm_definitions( -w14062 )
-
- # Suppress 'new behavior: elements of array 'array' will be default initialized'
- add_llvm_definitions( -wd4351 )
+ # Add definitions that make MSVC much less annoying.
+ add_llvm_definitions(
+ # For some reason MS wants to deprecate a bunch of standard functions...
+ -D_CRT_SECURE_NO_DEPRECATE
+ -D_CRT_SECURE_NO_WARNINGS
+ -D_CRT_NONSTDC_NO_DEPRECATE
+ -D_CRT_NONSTDC_NO_WARNINGS
+ -D_SCL_SECURE_NO_DEPRECATE
+ -D_SCL_SECURE_NO_WARNINGS
+
+ -wd4146 # Suppress 'unary minus operator applied to unsigned type, result still unsigned'
+ -wd4180 # Suppress 'qualifier applied to function type has no meaning; ignored'
+ -wd4224 # Suppress 'nonstandard extension used : formal parameter 'identifier' was previously defined as a type'
+ -wd4244 # Suppress ''argument' : conversion from 'type1' to 'type2', possible loss of data'
+ -wd4267 # Suppress ''var' : conversion from 'size_t' to 'type', possible loss of data'
+ -wd4275 # Suppress 'An exported class was derived from a class that was not exported.'
+ -wd4291 # Suppress ''declaration' : no matching operator delete found; memory will not be freed if initialization throws an exception'
+ -wd4345 # Suppress 'behavior change: an object of POD type constructed with an initializer of the form () will be default-initialized'
+ -wd4351 # Suppress 'new behavior: elements of array 'array' will be default initialized'
+ -wd4355 # Suppress ''this' : used in base member initializer list'
+ -wd4503 # Suppress ''identifier' : decorated name length exceeded, name was truncated'
+ -wd4624 # Suppress ''derived class' : destructor could not be generated because a base class destructor is inaccessible'
+ -wd4715 # Suppress ''function' : not all control paths return a value'
+ -wd4800 # Suppress ''type' : forcing value to bool 'true' or 'false' (performance warning)'
+
+ -w14062 # Promote "enumerator in switch of enum is not handled" to level 1 warning.
+ )
# Enable warnings
if (LLVM_ENABLE_WARNINGS)