summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2011-02-05 19:08:42 +0000
committerOscar Fuentes <ofv@wanadoo.es>2011-02-05 19:08:42 +0000
commit5a858e3416b13c2d796dfb9fc31f1e216e0acc2c (patch)
treec62ae7ee53f3e790aea79c776dbf0dff0a43d25e /CMakeLists.txt
parent479b4b9ef06dd84097202ffa6aea07913cdf651c (diff)
downloadllvm-5a858e3416b13c2d796dfb9fc31f1e216e0acc2c.tar.gz
llvm-5a858e3416b13c2d796dfb9fc31f1e216e0acc2c.tar.bz2
llvm-5a858e3416b13c2d796dfb9fc31f1e216e0acc2c.tar.xz
Moved more stuff to HandleLLVMOptions.cmake
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@124968 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt21
1 files changed, 0 insertions, 21 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index e436c1c757..41f4141140 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -34,20 +34,6 @@ This process created the file `CMakeCache.txt' and the directory `CMakeFiles'.
Please delete them.")
endif()
-# Run-time build mode; It is used for unittests.
-if(MSVC_IDE)
- # Expect "$(Configuration)", "$(OutDir)", etc.
- # It is expanded by msbuild or similar.
- set(RUNTIME_BUILD_MODE "${CMAKE_CFG_INTDIR}")
-elseif(NOT CMAKE_BUILD_TYPE STREQUAL "")
- # Expect "Release" "Debug", etc.
- # Or unittests could not run.
- set(RUNTIME_BUILD_MODE ${CMAKE_BUILD_TYPE})
-else()
- # It might be "."
- set(RUNTIME_BUILD_MODE "${CMAKE_CFG_INTDIR}")
-endif()
-
string(TOUPPER "${CMAKE_BUILD_TYPE}" uppercase_CMAKE_BUILD_TYPE)
set(LLVM_MAIN_SRC_DIR ${CMAKE_CURRENT_SOURCE_DIR})
@@ -118,13 +104,6 @@ set(FFI_INCLUDE_DIR "" CACHE PATH "Additional directory, where CMake should sear
set(LLVM_TARGET_ARCH "host"
CACHE STRING "Set target to use for LLVM JIT or use \"host\" for automatic detection.")
-set(LIT_ARGS_DEFAULT "-sv")
-if (MSVC OR XCODE)
- set(LIT_ARGS_DEFAULT "${LIT_ARGS_DEFAULT} --no-progress-bar")
-endif()
-set(LLVM_LIT_ARGS "${LIT_ARGS_DEFAULT}"
- CACHE STRING "Default options for lit")
-
option(LLVM_ENABLE_THREADS "Use threads if available." ON)
if( LLVM_TARGETS_TO_BUILD STREQUAL "all" )