summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorDouglas Gregor <dgregor@apple.com>2009-06-16 22:25:45 +0000
committerDouglas Gregor <dgregor@apple.com>2009-06-16 22:25:45 +0000
commit5dd4272c4780ce82641583a966168cade0c0f045 (patch)
tree1227dee0ce53e061f12acbec116df63db73f2961 /CMakeLists.txt
parent0ab28633c66a4dc996ab8d1eb1a882d19814df7f (diff)
downloadllvm-5dd4272c4780ce82641583a966168cade0c0f045.tar.gz
llvm-5dd4272c4780ce82641583a966168cade0c0f045.tar.bz2
llvm-5dd4272c4780ce82641583a966168cade0c0f045.tar.xz
CMake: Only include LLVM example executables in the build if requested by the user
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@73566 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt5
1 files changed, 4 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index de3e159476..543ee7f880 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -287,7 +287,10 @@ add_subdirectory(lib/Archive)
add_subdirectory(projects)
add_subdirectory(tools)
-add_subdirectory(examples)
+option(LLVM_EXAMPLES "Build LLVM example programs." OFF)
+if (LLVM_EXAMPLES)
+ add_subdirectory(examples)
+endif ()
install(DIRECTORY include
DESTINATION .