summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChris Lattner <sabre@nondot.org>2010-10-11 05:44:40 +0000
committerChris Lattner <sabre@nondot.org>2010-10-11 05:44:40 +0000
commit60cb528246dd01b80b1b1260a2a877ea488e620a (patch)
tree785116988a0a77a6d63c8972e543b3aada802e88 /CMakeLists.txt
parent335b806c627bf04eb079009abcc41e5d36f2ef22 (diff)
downloadllvm-60cb528246dd01b80b1b1260a2a877ea488e620a.tar.gz
llvm-60cb528246dd01b80b1b1260a2a877ea488e620a.tar.bz2
llvm-60cb528246dd01b80b1b1260a2a877ea488e620a.tar.xz
Per discussion with Sanjiv, remove the PIC16 target from mainline. When/if
it comes back, it will be largely a rewrite, so keeping the old codebase in tree isn't helping anyone. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@116190 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt6
1 files changed, 0 insertions, 6 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d473f51b59..414c32e005 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -64,7 +64,6 @@ set(LLVM_ALL_TARGETS
Mips
MBlaze
MSP430
- PIC16
PowerPC
PTX
Sparc
@@ -342,11 +341,6 @@ foreach(t ${LLVM_TARGETS_TO_BUILD})
set(CURRENT_LLVM_TARGET)
endforeach(t)
-# PIC16 contains an odd library:
-if( LLVM_TARGETS_TO_BUILD MATCHES ".*PIC16.*" )
- add_subdirectory(lib/Target/PIC16/PIC16Passes)
-endif()
-
# Produce llvm/Config/AsmPrinters.def
configure_file(
${LLVM_MAIN_INCLUDE_DIR}/llvm/Config/AsmPrinters.def.in