summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorSebastian Pop <spop@codeaurora.org>2012-08-08 17:45:43 +0000
committerSebastian Pop <spop@codeaurora.org>2012-08-08 17:45:43 +0000
commit6174fd7ed09e9d183d84fb3485a714c5b0c67e4a (patch)
treeedd9d0759bc7c8d976e7c8e4aa6f20a6d02a469b /CMakeLists.txt
parent8a403d326e7cb7e7ad6c0108d9e48b3e6ca47997 (diff)
downloadllvm-6174fd7ed09e9d183d84fb3485a714c5b0c67e4a.tar.gz
llvm-6174fd7ed09e9d183d84fb3485a714c5b0c67e4a.tar.bz2
llvm-6174fd7ed09e9d183d84fb3485a714c5b0c67e4a.tar.xz
enable Hexagon target from cmake
This patch allows us to use cmake to specify a cross compiler for Hexagon. In particular, the patch adds a missing case for the target Hexagon in cmake/config-ix.cmake, and it moves LLVM_DEFAULT_TARGET_TRIPLE and TARGET_TRIPLE variables from cmake/config-ix.cmake to the toplevel CMakeLists.txt to make them available at configure time. Here is the command line that I have used to test my patches: $ cmake -G Ninja -D BUILD_SHARED_LIBS:BOOL=ON -D LLVM_TARGETS_TO_BUILD:STRING=Hexagon -D TARGET_TRIPLE:STRING=hexagon-unknown-linux-gnu -D LLVM_DEFAULT_TARGET_TRIPLE:STRING=hexagon-unknown-linux-gnu -D LLVM_TARGET_ARCH:STRING=hexagon-unknown-linux-gnu -D LLVM_ENABLE_PIC:BOOL=OFF .. $ ninja check git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@161504 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt11
1 files changed, 9 insertions, 2 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index ed230aee5b..a3aee58d8d 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -116,8 +116,15 @@ option(LLVM_ENABLE_FFI "Use libffi to call external functions from the interpret
set(FFI_LIBRARY_DIR "" CACHE PATH "Additional directory, where CMake should search for libffi.so")
set(FFI_INCLUDE_DIR "" CACHE PATH "Additional directory, where CMake should search for ffi.h or ffi/ffi.h")
-set(LLVM_TARGET_ARCH "host"
- CACHE STRING "Set target to use for LLVM JIT or use \"host\" for automatic detection.")
+set(LLVM_TARGET_ARCH "host" CACHE STRING
+ "Set target to use for LLVM JIT or use \"host\" for automatic detection.")
+
+# By default, we target the host, but this can be overridden at CMake
+# invocation time.
+set(LLVM_DEFAULT_TARGET_TRIPLE "${LLVM_TARGET_ARCH}" CACHE STRING
+ "Default target for which LLVM will generate code." )
+set(TARGET_TRIPLE "${LLVM_DEFAULT_TARGET_TRIPLE}" CACHE STRING
+ "Default target for which LLVM will generate code." )
option(LLVM_ENABLE_THREADS "Use threads if available." ON)