summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorOscar Fuentes <ofv@wanadoo.es>2009-08-16 07:44:02 +0000
committerOscar Fuentes <ofv@wanadoo.es>2009-08-16 07:44:02 +0000
commit69e973d79b2c591ed706e81cfea052ad840e5102 (patch)
tree9592cf28e627a3b508c0b1e688f8ce03a30940be /CMakeLists.txt
parentb78829ee38d9939e3a19a151665dd6768f5e53c7 (diff)
downloadllvm-69e973d79b2c591ed706e81cfea052ad840e5102.tar.gz
llvm-69e973d79b2c591ed706e81cfea052ad840e5102.tar.bz2
llvm-69e973d79b2c591ed706e81cfea052ad840e5102.tar.xz
CMake: Hopefully this will fix the build on VS. I can't replicate the
failure with VS 9.0, nmake and cmake 2.6.4. The buildbot output does not show the patch level of cmake, it just says 2.6. Sadly, parallel builds are broken due to recent changes on LLVM Target libraries and its auxiliaries (TargetInfo, AsmPrinter, AsmParser). I have a patch for stablishing the correct dependencies, but cmake is buggy and generates makefiles that can't handle them. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@79180 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt1
1 files changed, 0 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 32dcae79f6..c8e86d0d3c 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -266,7 +266,6 @@ set(LLVM_ENUM_ASM_PRINTERS "")
set(LLVM_ENUM_ASM_PARSERS "")
foreach(t ${LLVM_TARGETS_TO_BUILD})
message(STATUS "Targeting ${t}")
- set(CURRENT_LLVM_TARGET ${t})
add_subdirectory(lib/Target/${t})
add_subdirectory(lib/Target/${t}/TargetInfo)
if( EXISTS ${LLVM_MAIN_SRC_DIR}/lib/Target/${t}/AsmPrinter/CMakeLists.txt )