summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2010-10-19 08:21:25 +0000
committerChandler Carruth <chandlerc@gmail.com>2010-10-19 08:21:25 +0000
commit6b241160eddc96ec098c74a041a327d545df6ff7 (patch)
treeda2b89979c7c48a88e4c0d06e54fa083c1f2d538 /CMakeLists.txt
parent94f7eeb84d8d25c647e560f352912ca1017ca10f (diff)
downloadllvm-6b241160eddc96ec098c74a041a327d545df6ff7.tar.gz
llvm-6b241160eddc96ec098c74a041a327d545df6ff7.tar.bz2
llvm-6b241160eddc96ec098c74a041a327d545df6ff7.tar.xz
First step to allowing the resource directory of Clang to be adjusted for
strange packaging environments. The primary result of this is to expose a (normally empty) CLANG_RESOURCE_DIR string in the autoconf and CMake builds. This will in turn be used by a subsequent commit to Clang. Regenerated configure and config.h.in thanks to Nick. =D git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@116802 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 19257201fc..4c182ff385 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -80,6 +80,9 @@ else( MSVC )
CACHE STRING "Semicolon-separated list of targets to build, or \"all\".")
endif( MSVC )
+set(CLANG_RESOURCE_DIR "" CACHE STRING
+ "Relative directory from the Clang binary to its resource files.")
+
set(C_INCLUDE_DIRS "" CACHE STRING
"Colon separated list of directories clang will search for headers.")