summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorChandler Carruth <chandlerc@gmail.com>2011-12-13 02:19:11 +0000
committerChandler Carruth <chandlerc@gmail.com>2011-12-13 02:19:11 +0000
commit6f20c61e07b570ad95fec81437972d653b362e63 (patch)
treee1624b243025693764154b58ca7707bb559fb4ae /CMakeLists.txt
parent63974b2144c87c962effdc0508c27643c8ad98b6 (diff)
downloadllvm-6f20c61e07b570ad95fec81437972d653b362e63.tar.gz
llvm-6f20c61e07b570ad95fec81437972d653b362e63.tar.bz2
llvm-6f20c61e07b570ad95fec81437972d653b362e63.tar.xz
Don't default the *cached* list of targets to build to an explicit list
of the targets we know about. Because this is cached, rebuilds won't detect when new targets show up. It's also a bit simpler to just say "all". If users want to restrict the target set, they can still do so, and then the cache will preserve what they have explicitly set this field to. git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@146467 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt2
1 files changed, 1 insertions, 1 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index d0dfbde0d8..ec42120d10 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -90,7 +90,7 @@ if( MSVC )
set(LLVM_TARGETS_TO_BUILD X86
CACHE STRING "Semicolon-separated list of targets to build, or \"all\".")
else( MSVC )
- set(LLVM_TARGETS_TO_BUILD ${LLVM_ALL_TARGETS}
+ set(LLVM_TARGETS_TO_BUILD "all"
CACHE STRING "Semicolon-separated list of targets to build, or \"all\".")
endif( MSVC )