summaryrefslogtreecommitdiff
path: root/CMakeLists.txt
diff options
context:
space:
mode:
authorAlexey Samsonov <samsonov@google.com>2013-03-26 07:49:46 +0000
committerAlexey Samsonov <samsonov@google.com>2013-03-26 07:49:46 +0000
commit777fccbe65f23d8a19bde1a8b69776c9a9209476 (patch)
tree2cec72d33df77a4ebaa676f91741bc93a4194c6d /CMakeLists.txt
parent0f3e4b149503d85403ec1181e5ffe9b60509c090 (diff)
downloadllvm-777fccbe65f23d8a19bde1a8b69776c9a9209476.tar.gz
llvm-777fccbe65f23d8a19bde1a8b69776c9a9209476.tar.bz2
llvm-777fccbe65f23d8a19bde1a8b69776c9a9209476.tar.xz
Add CMake option LLVM_USE_SANITIZER={Address,Memory,MemoryWithOrigins} to simplify bootstrap of LLVM/Clang under ASan/MSan
git-svn-id: https://llvm.org/svn/llvm-project/llvm/trunk@177992 91177308-0d34-0410-b5e6-96231b3b80d8
Diffstat (limited to 'CMakeLists.txt')
-rw-r--r--CMakeLists.txt3
1 files changed, 3 insertions, 0 deletions
diff --git a/CMakeLists.txt b/CMakeLists.txt
index 71a74260ab..80c95a08bc 100644
--- a/CMakeLists.txt
+++ b/CMakeLists.txt
@@ -193,6 +193,9 @@ if( LLVM_USE_OPROFILE )
endif( NOT CMAKE_SYSTEM_NAME MATCHES "Linux" )
endif( LLVM_USE_OPROFILE )
+set(LLVM_USE_SANITIZER "" CACHE STRING
+ "Define the sanitizer used to build binaries and tests.")
+
# Define an option controlling whether we should build for 32-bit on 64-bit
# platforms, where supported.
if( CMAKE_SIZEOF_VOID_P EQUAL 8 AND NOT WIN32 )